Rheem PowerVent Water Heater --- blower electrical receptacle

Users who are viewing this thread

RKS

New Member
Messages
1
Reaction score
0
Points
1
Location
19067
I have a rheem powervent 21vp75e-1 75 gallon tank that had an undiscovered leak from a pipe above that caused corrosion and unfortunately grounded out/short circuited the blower/exhaust fan outlet on top of the heater.

So the water heater will trip a breaker if the blower fan is plugged in to the top outlet --- the fan and heater still work well if the fan is plugged into an outlet separate from the heater. However, that method does not shut off the blower automatically when the water heater is no longer heating the water.

I have attached a picture and wiring schematic. Any clues on what is the solution to the shorted outlet?

IMG_20210927_105303277.jpg
IMG_20210923_170030477.jpg
 

John Gayewski

In the Trades
Messages
2,442
Reaction score
630
Points
113
Location
Iowa
From what I'm seeing the fan gets powered on through the thermostat of the water heater. You'll need to wire an outlet to power with your thermostat. Or any other combination of the many way you could do it. I'd recommend an electrician to keep it within electrical code.
 

Reach4

Well-Known Member
Messages
35,483
Reaction score
3,662
Points
113
Location
IL
So the water heater will trip a breaker if the blower fan is plugged in to the top outlet --- the fan and heater still work well if the fan is plugged into an outlet separate from the heater.
When you plug into the separate outlet, does that outlet have a working ground connection?

What is the resistance between the ground (roundish) plug contact and one of the plug blades?
 
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks