PermaHeat Bath Heater

Discussion in 'Shower & Bathtub Forum & Blog' started by Pegasus"143", Jun 21, 2010.

  1. Pegasus"143"

    Pegasus"143" New Member

    Joined:
    Jun 20, 2010
    Location:
    Tx
    PermaHeat Bath Heater Not Powering on.

    I purchased a Permaheat m/n 935113 heater and installed in new tub installation. My problem is that the heater power indicator light is not lit and no heat is produced when pump is running. It is plugged into a seperate GFCI outlet. Also this is a vacuum side pump. Any help with where to start diagnosis would be appreciated.
     
    Last edited: Jun 21, 2010
  2. Pegasus"143"

    Pegasus"143" New Member

    Joined:
    Jun 20, 2010
    Location:
    Tx
    :::UPDATE :::

    Found that there was not enough suction pressure to trip the vacuum switch. By partially blocking the suction port the unit switches on and begins to heat.

    Question now is the switch calibratable or does anyone no where I can order just a switch?
     
  3. Sponsor

    Sponsor Paid Advertisement

     
Similar Threads: PermaHeat Bath
Forum Title Date
Shower & Bathtub Forum & Blog Replace (Kohler?) bathtub faucet cartridge Saturday at 9:28 AM
Shower & Bathtub Forum & Blog Bathroom remodel - plumbing of the tub/shower Oct 13, 2017
Shower & Bathtub Forum & Blog Newby here, finishing bath valve installation, testing for leaks and yes, I've got em. Oct 10, 2017
Shower & Bathtub Forum & Blog Bath volume Oct 9, 2017
Shower & Bathtub Forum & Blog Can anyone please help me identify what brand bathtub this is? Oct 6, 2017

Share This Page