Ozone generator and injector assistance.

Users who are viewing this thread

Chucky5150

New Member
Messages
26
Reaction score
0
Points
1
Location
Louisiana, USA
Equipment list:
Ozone Generator - https://ozotech.com/aim-series/aim-pcs-400/
Ozone Injector - Mazzei Venturi Injector model 684


Ok, got some new equipment setup and installed. Everything looks to be installed correctly. This was a DIY install, and I am pretty confident in the work.
The injector is listed for 5 - 15 gpm.

My pump is putting out about 8.5 gallons per minute.
4.75 gallons / 33 seconds was the math used. Started with a full pressure tank.

For the life of me I am unable to get any kind of vacuum at the injection point. There have been a few times while draining the tank that it would get a little vacuum. Nothing while filling up a empty pressure tank or during normal pump cycles. While refilling an empty tank I can get about 10psi differential pressure. During the normal pump cycle I get closer to 5-8 psi differential.

I've had the injector port point down and tried with it point up (well, more like 11 o'clock) and that didn't make any difference.

I've checked a million times that the direction of flow is correct.


What else can I try?
 
Last edited:

Reach4

Well-Known Member
Messages
39,224
Reaction score
4,526
Points
113
Location
IL
You probably intended to include a photo.
 

Reach4

Well-Known Member
Messages
39,224
Reaction score
4,526
Points
113
Location
IL
Is this in line before the pressure tank? I would expect so.

Also, for venturi injectors, you may get more suction if the pressure switch is 30/50 rather than 40/60, because you are not fighting as much pressure. My comments are not based on my experience.
 
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks