New Geberit wall hung runs occasionally after flush?? - worse with faucet running?

Discussion in 'Toilet Forum discussions' started by edwardk, Mar 23, 2005.

  1. edwardk

    edwardk New Member

    Joined:
    Mar 23, 2005
    We have a new geberit concealed tank and duravit wall hung toilet.
    Occasionally, after flushing, the tank continues to pour water into the bowl so that the tank does not fill.

    I assume the flapper has not closed?

    The problem with these tanks is getting access to the parts - we can't even see the flapper.

    Anybody seen this before - any ideas?

    It seems to occur more frequently if the shower is on, or a faucet is running - but its also occurs when neither of these are on.

    The original plumber who did the install (as part of remodel) didn't have a clue and is not being helpful
    cheers
    Edward
     
  2. edwardk

    edwardk New Member

    Joined:
    Mar 23, 2005
    Anybody out there....? My toilet still underperforms :)

    Bumping the thread to get help.

    Will also contact Geberit customer support to see what they can do
     
  3. Sponsor

    Sponsor Paid Advertisement

     
Similar Threads: Geberit wall
Forum Title Date
Toilet Forum discussions Using integral power and water on Geberit wall carrier for TOTO bidet seat Apr 13, 2017
Toilet Forum discussions I have a Kohler wall mount toilet with a Geberit wall mount tank/ carrier Dec 13, 2016
Toilet Forum discussions Insulating behind Geberit in wall toilet tank. Apr 6, 2015
Toilet Forum discussions What's wrong with this in-wall Geberit and Duravit Toilet Install? Mar 21, 2015
Toilet Forum discussions Question about wall-hung Maris. Geberit and TOTO carriers Dec 9, 2013

Share This Page