Losing water when shallow jet pump kicks on?

Users who are viewing this thread

Paulont

New Member
Messages
6
Reaction score
0
Points
1
Location
northern ontario
hello all, i have a shallow jet pump with pressure tank that draws water from a lake, lately when the pump kicks on, i will lose water for about 3 seconds and then starts flowing again? is this the pump/check valve/clogged foot valve? what would cause this?
 

Reach4

Well-Known Member
Messages
35,483
Reaction score
3,662
Points
113
Location
IL
hello all, i have a shallow jet pump with pressure tank that draws water from a lake, lately when the pump kicks on, i will lose water for about 3 seconds and then starts flowing again? is this the pump/check valve/clogged foot valve? what would cause this?

This kicks on because of a pressure switch? It could be that your air precharge is too high and/or your pressure tank is too small.

Is it possible that the tube to the pressure switch is a bit clogged, so it takes time for the pressure switch to turn on?

Do you have a foot valve in the lake? A foot valve is a combo screen and check valve. If you do not use water, does the pressure hold up, or does it slowly drop?
 

Reach4

Well-Known Member
Messages
35,483
Reaction score
3,662
Points
113
Location
IL
Suction line leak.
I think that would have to be combined with a check valve upstream of the lake. Otherwise the system would restart periodically and would compensate.
 
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks