Increasing IGNITION / FLAME FAILURE on my water tank

Users who are viewing this thread

Chris_B

New Member
Messages
2
Reaction score
0
Points
1
Location
Ontario
I've got a GE Smart Water Heater (PowerVent) that's failing to ignite constantly, at first it would happen then be fine for a month or two, this past week it's now failing every hour at least, giving Error Code 6 - Ignition / Flame Failure (according to manual): https://webcache.googleusercontent....llivent_booklet.pdf+&cd=1&hl=en&ct=clnk&gl=us I can see the igniter glow bright but the flame doesn't catch half of the time, if I turn it off then on again and watch it's 50/50 if the flame catches.

I don't exactly want to have someone coming to my house to take a look at it right now (I doubt anyone is doing house calls now any how), so is there any troubleshooting steps I can safely perform myself?

Any feedback is much appreciated, thanks!

P.S. I've currently got it plugged into a smart outlet scheduled to restart every 2 hours, I can't imagine that's good for it either :(
 
Last edited:

MACPLUMB

In the Trades
Messages
1,079
Reaction score
77
Points
48
Location
HOUSTON, TEXAS
There 2 or 3 things that can be wrong, you need a Professional to Diagnose properly and Plumbers and Heating People are one of the
one's that can go to work Contact
Visit Customer Support Portal
  • +800-1-433-2682 (freephone 800)
  • +420-296-183-331.
 

Chris_B

New Member
Messages
2
Reaction score
0
Points
1
Location
Ontario
Pilot lights then what happens?

Sometimes the burner will ignite and it works, other times the pilot light (more of a glowing stick) goes off then one 2 more times then locks out and I need to power off/on again.
 
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks