Help with mono flow system

Users who are viewing this thread

rodney99

New Member
Messages
1
Reaction score
0
Points
0
I just had my boiler and pump replaced. 1st and 2nd floor seem to be fine giving heat but the basement rads are cold and they used to be really hot.

this is my system

http://highperformancehvac.com/boiler-hot-water-loops.html#monoflow_loop

my heating guy - doesn't seem to be familiar with monoflow systems. I am suspecting that either the pump is in the wrong direction or maybe the velocity is too slow or too fast to get monoflow t valves to operate.

The supply loop running along the ceiling is hot as hell but the pipes running to the rads below the supply loop are cold as hell.

Can you help.
 

hj

Master Plumber
Messages
33,509
Reaction score
956
Points
113
Location
Cave Creek, Arizona
Website
www.terrylove.com
mono-flo

Posting the MonoFlo site tells us nothing about YOUR system, it just tells HOW it should be installed. Basement radiators could be self venting, depending on how they are connected. For them to operate properly they must use TWO monoflow tees, feed and return, and the flow through them must be in the proper direction, meaning that the return may appear to be backwards if it is not labeled correctly.and they must be adequately spaced to produce a degree of flow resistance between them.
 
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks