Help with Culligan softener repair

Users who are viewing this thread

mjdodson05

New Member
Messages
2
Reaction score
0
Points
1
Location
63841
This is the system I have as pictured below... It's only about 5 years old but has stopped working properly, but for some reason, is still using salt. I have completely disassembled the brine tank and cleaned. It seemed to work fine for about 2 days, but then it stopped again. I'm a single mother and cannot afford to hire a plumber. I live in a very rural area and I'm on a private well with water that reeks of sulfur. Any help or suggestions would be greatly appreciated!!
Screenshot_20231020-041627.png
 

mjdodson05

New Member
Messages
2
Reaction score
0
Points
1
Location
63841
...also regenerates just fine and no error codes on display...also checked to make sure it wasn't on bypass...
 

GReynolds929

Active Member
Messages
224
Reaction score
68
Points
28
Location
WA
Don't know much about your softener issue but for the sulfur smell I got a product called the sulfur eliminator and it works great. Our well had a very strong sulfur smell.
Sulfur Eliminator
 

MaxBlack

Member
Messages
160
Reaction score
21
Points
18
Location
Northern Wisconsin
This is the system I have as pictured below... It's only about 5 years old but has stopped working properly, but for some reason, is still using salt. I have completely disassembled the brine tank and cleaned. It seemed to work fine for about 2 days, but then it stopped again. I'm a single mother and cannot afford to hire a plumber. I live in a very rural area and I'm on a private well with water that reeks of sulfur. Any help or suggestions would be greatly appreciated!!
I have the same system as you, but you need to explain what you mean by "stopped working properly". You say it "regenerates fine" so... what is happening (or not happening) to tell you it's not working.
 
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks