Search results

  1. elle

    Lukewarm cold water...help me solve the mystery!

    Thanks for your help! I keep trying to feel everything and it all feels room temperature, unless they are on. For the washer, the cold supply line only felt warm while I was running the washing machine and water was filling the basin. I guess my question is-- if the problem persists even when...
  2. elle

    Lukewarm cold water...help me solve the mystery!

    Yes, I have 3 bathroom sinks, 3 showers and the kitchen sink. I just thought it was odd it only happened once the kitchen faucet was replaced-- but the problem continued in other faucets after shutting the water supply off to the kitchen sink.
  3. elle

    Lukewarm cold water...help me solve the mystery!

    It doesn't look like my WH has a mixing valve in it and the cold water pipe remains room temperature. Any other ideas on how to find the source of the cross over?
  4. elle

    Lukewarm cold water...help me solve the mystery!

    I don't believe I have a recirc system-- (again I know NOTHING about plumbing, so I could very well be wrong). I will double check the lines at the WH while running cold water tonight. I did notice that while doing laundry on a COLD cycle, the cold water supply hose felt slightly warm. But...
  5. elle

    Lukewarm cold water...help me solve the mystery!

    As the title indicates, our cold water from ALL faucets starts out cold and within 20-30 seconds turns luke warm. This phenomenon started a month or so ago after a visit from a plumber. The plumber did the following: 1) Replaced a kitchen faucet with a Moen single handle 2) Replaced our washing...
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks