Re: Eljer toilet flapper refuses to stay up during flush
Posted by Ron on December 12, 2002 at 10:12:05:
In response to Re: Eljer toilet flapper refuses to stay up during flush
Hi Pete,
I recently purchased an Eljer Patriot toilet and had the same issue. I contacted Eljer and they sent me a new flapper. I figured it wouldn't fix the problem but tried the new one anyway. Needless to say, same type of flapper=same problem.

They then offered to reimburse me up to $100.00 to have the toilet removed. This was not the route I wanted to go and wondered why they would want to waste money like that. Afterall, I only paid around $135.00 for the toilet.

I went to Lowe's and found a Korky 1.6 GPF Adjustable flapper. It has a dial setting of 1-10. This basically controls how much water is flushed. The default setting of 6 worked great and my problem went away. Hope that helps!

: I bought a spec home two years ago and the builder put Eljer (aka JUNK) toilets in my house. The two upstairs work OK but I have one downstairs that has been causing me grief. I have a daylight basement, so I have a pump to get the waste from the downstairs toilet to the septic tank. The flapper that came with the tank degraded after only a year so I replaced it with a heavy duty red one. Yesterday I replaced it with a lighter duty black one hoping to solve the problem. Here is my problem. When I press the flush lever, the flapper is raised and the flush process starts. As soon as I let go, however, the flapped slams back down into the beginning position. I know this often happens if you don't push the lever down for about one second, but this happens no matter how long I hold down the lever. I watched the toilets upstairs and they have no problem in this department. I push the lever, the flapper comes up, the flapper stays up while the water goes down, the flapper goes down - normal. What is weird is in the one downstairs, the flapper is almost being sucked back into position. I just don't understand why it will not stay up like it is supposed to! Also - I do not think the flapper that came with the toilet worked well either. This toilet has always had this problem. Even when working the best it did, you still had to hold the lever for a good 3-4 seconds to get the water to go down.

: Any advise would be great - thanks.

Replies to this post