water softener not functioning
Posted by Steve Addison on June 06, 2002 at 14:55:01:
A few weeks ago, my softener brine tank filled all the way up and remained there
for several days, as the water in the tank continuously ran outof the overflow. I continued to get soft water
for a few days until (presumably) I ran out of salt. Then I turned it to "bypass". I have spent the last few
nights trying to fix it. I disassembled the inlet and the main and injector valves, looking for sticking or
blockage.
Having found none, I checked the timer function. The timer appears to be working perfectly and the
control seems to cycle the valves correctly. I'm wondering if the "regen" cycle is working, since I don't
hear the water rush into the softener cylinder
when its in the "regen" cycle. I do notice the backflush and rinse cycles seem to work, judging by the
water discharged from the hose. I took the brine tank out and cleaned it before putting it
back in service. I put a few gallons in by hand and the level seems to maintain lower than it had previously
when it worked correctly, but it isn't dry.
I'm stumped. The softener appears to be functioning, I think salt is being consumed,
but no soft water. I have the feeling I'm overlooking something simple, and I don't want to
buy a new one if that's true, even if the local home supply people tell me that's all that can be done.
Moreover, I don't even know if putting in a new one will fix the problem at all.
What else should I look for in order to solve this? I can't even
find the manufacturer (AquaMaster) on the internet, and local contractors have not heard of it.


Replies to this post