well water sediment filter question

Discussion in 'Plumbing Forum, Professional & DIY Advice' started by bronzemaxell, Jul 26, 2010.

  1. bronzemaxell

    bronzemaxell New Member

    Messages:
    9
    Location:
    earth
    i went to lowes and saw they have the whole house whirlpool brand sediment filter with 1" thread, so i bought one, and to try.

    is it a good idea to put a sediment filter before or after the pressure tank (120 gallon)?

    i am also trying to install the Calcite filter with 2510sxt control valve and water softner with 2510 sxt control valve. does the AN filter or water softner also have built-in sediment filter?

    it is the first time i've seen how the well water looks like through the clear plastic sediment filter housing after pump from well. initially very muddy, like coffee, then it clears up.

    my concern is after a couple time of pumping, the sediment filter is basically brown, and i can see sand being collected in the bottom of the filter housing, and i am afraid the filter will restrict the flow of water from pump, and putting extra work load on the pump.

    [​IMG]
  2. Doherty Plumbing

    Doherty Plumbing Journeyman & Gas Fitter

    Messages:
    810
    Location:
    Penticton, BC
    I would probably install it after the pressure tank.
  3. bronzemaxell

    bronzemaxell New Member

    Messages:
    9
    Location:
    earth
    ok, thanks for your advice
    i am thinking to installing a chemsorb sediment filter with auto backwash 2510 control timer after my pressure tank, between the calcite filter and water softner.
Similar Threads: water sediment
Forum Title Date
Plumbing Forum, Professional & DIY Advice Sediment in water after flushing the pipes Jan 14, 2014
Plumbing Forum, Professional & DIY Advice Water Well Line - Sediment Filter - Expansion Tank - Water Softener - H2O Htr. Order? Apr 6, 2011
Plumbing Forum, Professional & DIY Advice dark sediment in well water Jan 15, 2011
Plumbing Forum, Professional & DIY Advice Green sediment in water May 13, 2010
Plumbing Forum, Professional & DIY Advice Hot water stops and odd sediment in the lines Apr 25, 2010

Share This Page