Well Pump Running

Discussion in 'Pumps and Tanks Well Forum & Blog' started by garysivertson, Apr 22, 2012.

  1. garysivertson

    garysivertson New Member

    Messages:
    1
    Location:
    Chesapeake, Virginia
    I have 3/4 HP Sta Rite Pump that will not stop running. I have installed a new 30 to 50 pressure switch and 0 to 100 PSI gage. No leaks in the system. Pressure tube is clear. Bladder tank is set at 27 psi. Pump will buld pressure to 55 PSI and hold that 55 PSI after it is unplugged. Pump will not stop running with all valves shut. You can open the the faucet at the pump pressure will drop down to 35 PSI, close the faucet and the pressure will build back up to 55 PSI and keep running. Attempted to lower the cut out pressure on switch to 45 lbs and pump still will not cut out.
  2. cacher_chick

    cacher_chick Test, Don't Guess!

    Messages:
    3,249
    Location:
    Land of Cheese
    Was anything done before this problem was noted? If the pump will not build over 55, either the pump is shot or there is a leak in the drop pipe down inside the well.
  3. valveman

    valveman Moderator Staff Member

    Messages:
    4,485
    Location:
    Lubbock, Texas
    55 may just be all that pump can do. But you have a 30/50 switch, so the pump should have shut off at 50 PSI. I think you just need a good pressure switch.
  4. Tom Sawyer

    Tom Sawyer In the Trades

    Messages:
    3,225
    Location:
    Maine
    Take a screwdriver and pry up on the switch plate in the pressure switch with the pump running. If it shuts off then either

    Bad pressure switch
    Pump is not producing enough pressure to shut it off
    something is wired wrong (probably the pressure switch)
Similar Threads: Pump Running
Forum Title Date
Pumps and Tanks Well Forum & Blog Well Pump Running Intermittently Oct 12, 2014
Pumps and Tanks Well Forum & Blog Ejector Pump running in basement after water usage on main floor May 26, 2014
Pumps and Tanks Well Forum & Blog Cost of running 1.5hp vs 3.0hp well pump Jan 9, 2014
Pumps and Tanks Well Forum & Blog Another question on running well pumps Dec 17, 2013
Pumps and Tanks Well Forum & Blog VERY low water pressure but pump keeps running Oct 9, 2013

Share This Page