Well pump only runs when I hold switch manually

Discussion in 'Pumps and Tanks Well Forum & Blog' started by jiggypiggy, Dec 7, 2010.

  1. jiggypiggy

    jiggypiggy New Member

    Messages:
    5
    Location:
    Winnipeg, MB
    I just had a new red jacket pump installed and it has a centripro AS4CB pressure switch on it. I lost power and now pump wont start. I read posts here and other places that say there should be a reset switch thingy on the side, like a little lever that you hold up until there is enough pressure, then it works on its own. Mine does not seem to have that. I took the lid off the pressure control box and found it has power going to some magnet things. Then there is a black piece of plastic that has metal on it. Looks like the magents are supposed to suck the plastic/metal towards it. When I push the plastic to the magents, the pump kicks in and I get water. Just cant get it to kick in once I use up the water in holding tank. Not sure why this would happen. I thought plumber did a good job and its been working (3 days seemed fine). Is there some other type of reset switch? Also, I do not have a pressure guage on the pump.
  2. masterpumpman

    masterpumpman New Member

    Messages:
    729
    Location:
    Virginia Beach, VA
  3. justwater

    justwater Well Drilling/Service

    Messages:
    327
    Location:
    FL/GA
    if its only been 3 days, i'd call them.. unless he didnt supply the parts in which case he might not have to honor any warranty.
    Last edited: Dec 8, 2010
  4. jiggypiggy

    jiggypiggy New Member

    Messages:
    5
    Location:
    Winnipeg, MB
    Just a quick thank you. Works now, needed to get a heater blowing right on pressure switch, works fine now.
  5. ballvalve

    ballvalve General Engineering Contractor

    Messages:
    3,261
    Location:
    northfork, california
    The magnetic thingie would likely be a magnetic contactor or motor starter. If the pressure switch is froze up, it will not get a signal to close.

    You probably have a pump control box, which takes the heavy starting load off of the pressure switch. Its a very good system.
    Last edited: Jan 4, 2011
Similar Threads: pump runs
Forum Title Date
Pumps and Tanks Well Forum & Blog Help diagnosing a well pump that runs every 10 minutes Apr 20, 2014
Pumps and Tanks Well Forum & Blog Deep well jet pump runs but no output Jan 8, 2014
Pumps and Tanks Well Forum & Blog Supply line froze, after thawing water runs back into well when pump stops... Jan 4, 2014
Pumps and Tanks Well Forum & Blog Pump Runs Non Stop trying to reach cut off pressure setting May 6, 2013
Pumps and Tanks Well Forum & Blog Another pump-runs-continuously-but-tank-not-filling thread Mar 8, 2013

Share This Page