Waterguard Aerator Noise

Discussion in 'Pumps and Tanks Well Forum & Blog' started by zver11, Apr 18, 2013.

  1. zver11

    zver11 New Member

    Messages:
    12
    Location:
    Philadelphia pa
    I installed a Waterguard Radon Aerator. It involves a sprayer and a repressurization pump(submersible 1/2 HP in sprayer tank) and output pressure tank/pressure switch. Output gear similar to well pump equipment. The problem is a loud thump sound every time the pump turns off. Loud enough to be heard in much of the house (unit is in basement). Pressure tank at 38PSI precharge. Pressure switch was at 60/40. Tried lowering to 55/40 to see if noise affected. No change.

    Any advise on noise abatement? Is this noise normal in a well pump with the noise not heard because it is too far away or is this something that can be improved with some adjustments to setup?
  2. LLigetfa

    LLigetfa DIYer, not in the trades

    Messages:
    3,901
    Location:
    NW Ontario, Canada
    My guess is that the aeration may be precipitating some elements in the water and that is causing the checkvalve to gunk up and not close fast enough. The result is a sudden backrush of water and subsequently the checkvalve slamming shut creating water hammer.

    Most pumps use a checkvalve without any springs. Probably the simplest fix would be to install a spring-loaded checkvalve directly on the output of the pump..
  3. zver11

    zver11 New Member

    Messages:
    12
    Location:
    Philadelphia pa
    Notice at plumbingsupply.com, a magnetic spring loaded check valve. Claim quieter than normal spring loaded. Any opinion on this?

    Pump is Sta-rite DM series. Not sure if existing check valve is internal or mounted just at mouth of pump. Does this need to be removed or just install another check valve downstream? Assembly provided by aerator maker has pump connected to approx 4" light blue segment then dark grey plastic pipe (not look like ABS) to 1.25" PVC union. Light blue segment is cylindrical and not noticeably thicker than pipe. Is it possible light blue segment is existing check valve?

    Also if I install another valve downstream, can it be upside down? Anything external to tank would need to be upside down given piping configuration.
  4. zver11

    zver11 New Member

    Messages:
    12
    Location:
    Philadelphia pa
    Never mind on magnetic--not suitable for application. Is there any reason not to just use the spring loaded PVC valves at Home Cheapo? Being above ground, not as big a penalty if they fail as something hundreds of feet underground.
  5. LLigetfa

    LLigetfa DIYer, not in the trades

    Messages:
    3,901
    Location:
    NW Ontario, Canada
    I'm not a fan of cemented PVC. Threaded PVC is fine for the male ends but prefer brass or SS threaded female.
  6. zver11

    zver11 New Member

    Messages:
    12
    Location:
    Philadelphia pa
    Installed acetal plastic check valve exactly identical to original except now has spring installed (apparently manufacturer sells same valve with and without spring) Water hammer gone but now a new problem has appeared on reassembly.

    When the pump runs, there is a load grinding noise. Any ideas as to cause or solution?
  7. LLigetfa

    LLigetfa DIYer, not in the trades

    Messages:
    3,901
    Location:
    NW Ontario, Canada
    Did the pump have a shroud? Often a shroud is used on a pump inside a tank to keep it from sucking air. The sound you describe is what one might hear if there is air getting into the pump. The air will cause cavitation that will destroy the pump.

    If the shroud was not sealed properly at the top, air might be getting sucked into the pump.
  8. zver11

    zver11 New Member

    Messages:
    12
    Location:
    Philadelphia pa
    There is no shroud as such. It is in a 5' tall tank with the pump vertically mounted with the intake near the bottom of the tank. The water level is well above the pump intakes at all times(safety float shuts off pump is depth to low). There is no turbulence visible on the water's surface when the pump is running.

    I removed the pump from the water to see the check valve and kept the pump on the workbench for several days while waiting for the replacement to arrive so any water inside the pump would have drained out. But it has now been submerged for days. Is this a noise that can go away after running the pump for a while or should I avoid using it until the problem is solved? The aerator tank is currently in bypass mode so the house still has water.
Similar Threads: Waterguard Aerator
Forum Title Date
Pumps and Tanks Well Forum & Blog water jets not shutting off on well aerator tank Feb 5, 2014
Pumps and Tanks Well Forum & Blog Appreciate advice on replacing bacteria filled aerator Feb 3, 2014
Pumps and Tanks Well Forum & Blog well constintaly fills aerator tank Dec 24, 2011
Pumps and Tanks Well Forum & Blog my aerator is full of water but I have none May 5, 2011
Pumps and Tanks Well Forum & Blog Location of CSV and Aerator on Iron Remover Apr 15, 2011

Share This Page