Water softener problem

Discussion in 'Plumbing Forum, Professional & DIY Advice, Tips & ' started by Jeff Richardson, Jun 4, 2006.

  1. Jeff Richardson

    Jeff Richardson New Member

    Messages:
    2
    Location:
    NC
    I've owned a fleck 7000 water softener for about 2 months. About a week ago the unit went into regeneration mode and didn't stop discharging into the drain for 2 days(my wife later told me, as I was out of town when this occured). I told her to unplug the unit, but didn't help, then I told her just put it in bypass till I get home. I got it to stop discharging, but the flow light on the display won't shut off. There is no water flowing anywhere in the house or outside spigot's. The light does not blink, it is solid. The unit seems to be operating correctly, but I don't trust it yet. Any idea's what the problem is. I find myself checking on it a couple of times a day, as I don't want water to be pouring down the drain for hours on end. Thanks.
  2. Gary Swart

    Gary Swart In the Trades

    Messages:
    7,328
    Location:
    Yakima WA
    Keep checking this site. The is a regular that is a water softener pro and can address your problem.
  3. Gary Swart

    Gary Swart In the Trades

    Messages:
    7,328
    Location:
    Yakima WA
  4. Gary Slusser

    Gary Slusser That's all folks!

    I'm a bit late but here I am. Water running to drain means the piston is stuck in a cycle of a regeneration. Unplugging the unit never does anything but prevent the value form moving to the next position or back to service. Always by pass a problem control valve.

    If you have returned the unit to service and the flow light does not flicker when you run water, the turbine wheel/fan isn't rotating or there is a circuit board or meter cable connection problem OR possibly the valve is not indexed correctly. Check the set up and troubleshooting part of your manual.

    Remove, you won't enjoy doing that due to the difficulty, and clean the meter turbine and the area it is installed in. While you have the turbine out (with the control plugged in), blow on it in the correct water flow direction and see if the turbine spins freely and if the light flickers. If not see above. And ya shouda bought the Clack WS-1 instead of the Fleck 7000... if needed, you'd enjoy removing/cleaning the turbine and have it done in all of 5 minutes. :)
  5. Jeff Richardson

    Jeff Richardson New Member

    Messages:
    2
    Location:
    NC
    Thanks for the T/S Gary. With your info and the manual I should be able to tackle it this weekend. If I have any problems I know where to post. Thanks again.
Similar Threads: Water softener
Forum Title Date
Plumbing Forum, Professional & DIY Advice, Tips & Water softener installation problem Jul 18, 2014
Plumbing Forum, Professional & DIY Advice, Tips & Water Softener Drain Line Question Jul 11, 2014
Plumbing Forum, Professional & DIY Advice, Tips & new water softener - sizing - type - etc Jun 27, 2014
Plumbing Forum, Professional & DIY Advice, Tips & Need Advice Please Water Softener/Condenstate Drain Backup Issue Feb 1, 2014
Plumbing Forum, Professional & DIY Advice, Tips & Water Softener question Dec 31, 2013

Share This Page