Water Softener problem

Discussion in 'Plumbing Forum, Professional & DIY Advice' started by bjp, Aug 27, 2008.

  1. bjp

    bjp New Member

    Joined:
    Aug 27, 2008
    Hi... I have a 6 month old softener, a Professioanl Series by Water Technologies, Inc. Whenever it regenerates, we get lots of air in our pipes. So much that when we turn the shower on, it spits and pops and shudders for 2-3 minutes. In addition, I still have some hard water deposits. Any suggestions? Thanks!
     
  2. Gary Slusser

    Gary Slusser That's all folks!

    Joined:
    Aug 31, 2004
    Occupation:
    Retired
    Location:
    Wherever I park the motorhome.
    The most common cause of that is loose brine line connections allowing it to suck air or the brine pick up tube's air check is not closing and that allows air into the resin tank but... if you are on your own well, the water level in the well could be down to the inlet of the pump or foot valve allowing the pump to suck air.
     
  3. Sponsor

    Sponsor Paid Advertisement

     
  4. bjp

    bjp New Member

    Joined:
    Aug 27, 2008
    I'll check it out. Thanks for the help--have a great day!!:)
     
Similar Threads: Water Softener
Forum Title Date
Plumbing Forum, Professional & DIY Advice Quick question about water softener. Brine tank is soapy. Is that normal? (with picture) Oct 18, 2014
Plumbing Forum, Professional & DIY Advice Water softener installation problem Jul 18, 2014
Plumbing Forum, Professional & DIY Advice Water Softener Drain Line Question Jul 11, 2014
Plumbing Forum, Professional & DIY Advice new water softener - sizing - type - etc Jun 27, 2014
Plumbing Forum, Professional & DIY Advice Need Advice Please Water Softener/Condenstate Drain Backup Issue Feb 1, 2014

Share This Page