Water Quality/chaulky water?

Discussion in 'Water Softener Forum, problems, installation and r' started by billfig, Apr 23, 2011.

  1. billfig

    billfig New Member

    Joined:
    Feb 24, 2011
    Location:
    upstate NY
    It seems more apparent on non metal materials and after going thru the dishwasher? The silverware doesnt shine as well either. I just put the Kenmore Softener in within the past 6 mos. It seemed to develop after I replaced my diaphram tank setup a few weeks ago. I checked & cleaned the venturi assy(thinking it was plugged). Actually when I think about it, the water seems fairly soft when washing hands/shower etc. ? So strange? water tested at 30-34 hardness many years ago..:confused:
     
  2. Smooky

    Smooky Member

    Joined:
    Apr 4, 2011
    Location:
    NC
    I don't really know but if the hardness is less than 30, the water becomes corrosive. Are you sure you needed the water softener? Another thought, I think the softener adds sodium to the water.
     
  3. Sponsor

    Sponsor Paid Advertisement

     
  4. mialynette2003

    mialynette2003 Member

    Joined:
    Nov 24, 2010
    Occupation:
    Owner of SWS Systems WWW.SWSSYSTEM.COM
    Location:
    Ocala, Florida
    Water only becomes corrosive when the pH falls below 7, not when you remove hardness.
     
  5. billfig

    billfig New Member

    Joined:
    Feb 24, 2011
    Location:
    upstate NY
    I think maybe I'll have my water analyzed to see where my base is..:)
     
Similar Threads: Water Quality/chaulky
Forum Title Date
Water Softener Forum, problems, installation and r GFCI for water softener in garage? Tuesday at 5:11 AM
Water Softener Forum, problems, installation and r Water softener ??? Sunday at 8:46 PM
Water Softener Forum, problems, installation and r Fleck 5600 Ecominder - Salt setting for very hard water Feb 22, 2015
Water Softener Forum, problems, installation and r WaterGroup STF20-860 Program dial not moving Feb 20, 2015
Water Softener Forum, problems, installation and r No soft water / no salt usage with Kenmore 300 Feb 17, 2015

Share This Page