Toto Dual flush - not filling

Discussion in 'Toilet Forum discussions' started by dpw-ct, Dec 27, 2013.

  1. dpw-ct

    dpw-ct New Member

    Feb 18, 2012
    New York
    I have had a Toto Aquia® One-Piece Toilet, Dual Flush toilet (1.6GPF & 0.9GPF Model MS654114MF) for a couple of years and all of a sudden it stopped filling. Any advice on what this might be. Sediment ? other common causes. Need advice on how to fix.

    Thanks all
  2. Terry

    Terry Administrator Staff Member

    Aug 17, 2004
    Bothell, Washington
  3. Sponsor

    Sponsor Paid Advertisement

  4. wjcandee

    wjcandee Wise One

    Apr 27, 2012
    New York, NY
    If after servicing the valve it doesn't solve the problem, turn off the water to the toilet, disconnect the supply hose from the valve, and holding the hose over a bucket or something turn the water and see if any comes out the hose in a good flow. If not, then you may have a defective FloodStop hose (that is supposed to cut off for excessive flow). Replace it with a normal hose and you should be fine.

    Korky video on servicing the valve (Korky makes the green-capped fill valve that Toto uses in the Aquia):

    Last edited by a moderator: Aug 26, 2014
Similar Threads: Toto Dual
Forum Title Date
Toilet Forum discussions American Standard Dual Flush or Toto Entrada? Nov 11, 2015
Toilet Forum discussions Recommendations for new toilet: Toto Drake or a dual flush? Nov 9, 2015
Toilet Forum discussions 1-piece, dual flush: Toto Aquia or AS Boulevard? Feb 23, 2015
Toilet Forum discussions Toto Aquia dual flush price & availability Jan 1, 2015
Toilet Forum discussions Toto Aquia Dual Toilet with leak at connection of supply line and fill valve Mar 13, 2014

Share This Page