Sump pump troubles

Discussion in 'Plumbing Forum, Professional & DIY Advice, Tips & ' started by Dave3103, Oct 30, 2008.

  1. Dave3103

    Dave3103 New Member

    Messages:
    1
    Hello All,

    Just looking for some advice.
    I have installed a "sump buddy" to clear the sump water during power outages. It's just a float switch that allows city water to drive a venturi pump. The problem I'm having is when the float valve is activated the output is no more that a low flowing dribble, if I hold the float valve open and close the inlet ball valve, then open the ball valve - the output is great. This only works when I manually actuate the inlet water supply. I opened the valve assembly and there is nothing unusual, the body of the valve is exactly the same as a solenoid style valve.
    I know I should just take the thing back but once this thing is installed it's a real pain to take apart, and I cannot find anything wrong. Possible high pressure locking up the valve?
Similar Threads: Sump pump
Forum Title Date
Plumbing Forum, Professional & DIY Advice, Tips & Sump Pump & Gutter Drains Jun 20, 2014
Plumbing Forum, Professional & DIY Advice, Tips & Banging pipes from sump pump Jun 14, 2014
Plumbing Forum, Professional & DIY Advice, Tips & 225' of sump pump drain to run... PVC or polyethylene? Jun 9, 2014
Plumbing Forum, Professional & DIY Advice, Tips & Setting up pump in sump pit to pump to sidewalk if sewer line is backed up May 27, 2014
Plumbing Forum, Professional & DIY Advice, Tips & Sewage sump pump and discharge pipe install questions Apr 10, 2014

Share This Page