Sediment in Well Water

Discussion in 'Pumps and Tanks Well Forum & Blog' started by Northern MD, Aug 9, 2011.

  1. Northern MD

    Northern MD New Member

    Messages:
    2
    Location:
    MD
    I have a 23-year old, 240 ft well. About 15 years ago I replaced my submersible well pump and added torque arresters. Had to replace my tank about 10 years ago and found lots of sediment in tank. Raised the pump about 5 ft. Just replaced my tank again and found more sediment. Someone said the torque arrestors may be knocking dirt from the sides of the hole into the water. Any suggestions?
  2. masterpumpman

    masterpumpman New Member

    Messages:
    729
    Location:
    Virginia Beach, VA
    I doubt that a torque arrestor would cause sediment. It's more likely that the well is producing sediment however sediment in the tank is sometimes normal. Question? Is there sediment in the toilet tank when you remove the top or sediment in the hot water tank when you let water out of the drain? If not I wouldn't worry about it!
  3. Northern MD

    Northern MD New Member

    Messages:
    2
    Location:
    MD
    No sediment, just some discoloration. No sediment in hot water heater.
Similar Threads: Sediment Water
Forum Title Date
Pumps and Tanks Well Forum & Blog Water rusty and full of sediment after new submersable well pump was installed May 17, 2013
Pumps and Tanks Well Forum & Blog I have a silver sediment in all my water after well was redrilled! Mar 31, 2013
Pumps and Tanks Well Forum & Blog Black Fine Sediment well water Jan 3, 2012
Pumps and Tanks Well Forum & Blog Question for installing sediment filter and water softener. Sep 3, 2011
Pumps and Tanks Well Forum & Blog Well Water Black sediment in my Whole house water filter (YUK} Jul 29, 2011

Share This Page