Rinnai 556FA wall furnace failure/error

Discussion in 'HVAC Heating & Cooling' started by dave2664, Mar 6, 2011.

  1. dave2664

    dave2664 New Member

    Messages:
    5
    Have a 5+ year old Rinnai 556FAIII Rinnai Gas Direct Vent Wall Furnace. Recently having problems with an error/shut down of unit. About a month ago, the unit went into error mode. I fixed it by pulling the cord and restarting. Now, the unit goes into complete error and restarting will not fix the problem. The unit reads flame failure. Every time a call for heat initiates, the heater will go through its normal startup procedure. I can hear the sparker, see the flame ignite and the blower activate. After about 3 seconds, the flame cuts out and the blower continues runnning putting out cold air. Tried searching the boards with no luck. A service call in my neck of the woods runs $250.00 +. Any help greatly appreciated.....

    Thanks
  2. jadnashua

    jadnashua Retired Defense Industry Engineer xxx

    Messages:
    22,262
    Location:
    New England
    It is not confirming that the burner ignited, so it is shutting itself off and running a purge cycle. It might repleat that a few times before it shuts down with an error message. The flame sensor itself might be dirty - cleaning it might help. It could be out of position (unlikely unless you'd been in there cleaning things), the flame could be messed up so it is not actually hitting the sensor, the sensor could be bad and needs to be replaced, or the circuit that 'reads' the flame sensor is either bad, or there's a loose connection getting it there.

    Depending on the type of sensor, you may be able to easily test it - it would be described in the maintenance manual. I'd look at it, clean it if it's dirty (maybe some steel wool - depends on the type), and make sure that where it is, the flame actually hits it.

Share This Page