pump losing its prime

Discussion in 'Pumps and Tanks Well Forum & Blog' started by joefla, Nov 26, 2006.

  1. joefla

    joefla New Member

    Messages:
    2
    I have a shallow well (21'). My old pump was constantly cycling, so I replaced the pressure switch. That didn't cure it, so I installed a cut off valve on my line in, while I was at it, I figured I may as well replace the pump with a new one, which I did. 1 HP. Now the cycling problem stopped, buttt now I have a problem of my pump losing its prime. I have a 30/50 pressure switch in this. There are no air leaks in the system from my install. Any suggestions or help in this? This is a inside, above ground pump with a pressure tank, which by the way is NOT water logged. I set pressure in the tank to 28 psi prior to firing it all up.
    Thanks, Joe
  2. speedbump

    speedbump Previous member

    Messages:
    4,540
    Location:
    Riverview, Fl.
    How do you know there are no air leaks? You can't see them. What horsepower was the old pump? What kind and size of tank do you have?

    bob...
  3. Pumpman

    Pumpman Pump Sales

    Messages:
    191
    Location:
    So. Cal
    Did you happen to replace the footvalve while you were installing the new pump?
    Ron
  4. joefla

    joefla New Member

    Messages:
    2
    OK no air leaks on all the visible pipes, which are above ground inside house. I replaced the old 1 hp pump with a new 1 hp pump. I haven't been able to replace the foot valve, due to me not knowing where the well is actually at on the property. I am guessing that it might be the main source of the problem. Is there a way to clean out the foot valve somehow, either by forcing air down there or do I actually have to find my well and take it from there?

    Also, is there a some what easy way to adjust the pressure switch, it seems that the pressure kicks on at about 26 PSI and off at 52 PSI. I know its a 30/50 switch on the unit. The are "2" adjust ment nuts on the switch, a large one and a small one. Thanks
    Last edited: Dec 2, 2006
  5. Pumpman

    Pumpman Pump Sales

    Messages:
    191
    Location:
    So. Cal
    I'd guess that the footvalve was your problem all along. Unfortunately, you'll need to locate the well to replace the footvalve.
    The taller of the two springs will adjust both the cutin and cutout pressures. The shorter will adjust the cutout only.
    Ron
Similar Threads: pump losing
Forum Title Date
Pumps and Tanks Well Forum & Blog Tankless Submersible Well Pump losing pressure Jul 7, 2014
Pumps and Tanks Well Forum & Blog Pump Losing Prime Quickly Nov 27, 2012
Pumps and Tanks Well Forum & Blog Pump losing pressure fast. Mar 18, 2011
Pumps and Tanks Well Forum & Blog Jet Pump losing prime whgile running Jan 12, 2011
Pumps and Tanks Well Forum & Blog Losing Pressure with my jet pump and don't know where the heck is the well. Sep 8, 2010

Share This Page