Problems with my fleck valve, clicking noise

Discussion in 'Water Softener Forum, problems, installation and r' started by acrod, Jun 5, 2010.

  1. acrod

    acrod New Member

    Messages:
    14
    Location:
    tx
    I have been having problems with fleck 8500 twin valve over the past few months, during the start of the cycle the gears start making this clicking noise and do not advance the cycle. I have been able to push the gear to get it going again and then it starts clicking and won't go anywhere. I took apart all the small plastic gears behind the control panel and there were no stripped teeth, everything looked as it should. I thought maybe it might have been the motor going out which I replaced but it is still doing the same thing. I have had it on bypass for the last 6 months as I can't seem to get it fixed, this water softener has been nothing but trouble for me since I bought it 3 years ago and I am ready to trash it!! Please help.
  2. Gary Slusser

    Gary Slusser That's all folks!

    It's probably a sticking piston and you need new seals, spacers a and piston, you have two of them in that valve; main and upper. Or it could be the brine piston sticking.
  3. acrod

    acrod New Member

    Messages:
    14
    Location:
    tx
    I'm pretty mechanically inclined, is that difficult to do? Is this normal for a three year old softener, I know anything mechanical can break but you would think it wouldn't break down so early. How would I know which piston it is? Thanks.
  4. Akpsdvan

    Akpsdvan In the Trades

    Messages:
    1,487
    Location:
    Alaska
    It is kind of a pain ... the 8500 can be rebuilt,, just did one and ...

    Is it the older style of the new SE or SXT?
  5. acrod

    acrod New Member

    Messages:
    14
    Location:
    tx
    I'm not too sure, the manual says twinflo e. So it can be done without calling a professional? Is it worth it to rebuild it, or should I just buy a less expensive single tank meter, and be done with it? A two tank system is way more than my house needs anywas
  6. Akpsdvan

    Akpsdvan In the Trades

    Messages:
    1,487
    Location:
    Alaska
    Does it have a digital control?

    It depends on where the clicking is coming from and what is making it click as to how costly it is going to be.

    A side note, the 8500 is coming to an end, Fleck or Pentair is no longer going to be making them if they have not already stopped making them.

    The 9100 is a much better and trouble free valve and would use the same meter turbin and bypass and brine tank and media tanks that you already have in place.

    While it might be more than your house of today might need, if you sell the place could a larger family move into your house?
  7. acrod

    acrod New Member

    Messages:
    14
    Location:
    tx
    Digital control valve, the clicking seems to be coming from the downflow cam thing. Area. (Sorry, I'm not too versed in softener terms).
  8. Akpsdvan

    Akpsdvan In the Trades

    Messages:
    1,487
    Location:
    Alaska
    Not a problem.
    There is a cam that moves the backwash piston in and out and also pushes the brine piston in for brine draw. There could be some thing not right and a noise is coming from it.
    There is the white cam on the front that controls the micro switchs for stopping the cam at each step of the cleaning cycle.
    There is a little like lock key on the big cam that controls the piston and brine piston, if that key gets taken out by the white cam locking then they will not turn in cynic ...
  9. acrod

    acrod New Member

    Messages:
    14
    Location:
    tx
    Yes it seems to be coming from the white cam, but not 100% sure. Is there any way to Pinpoint the problem?
  10. Akpsdvan

    Akpsdvan In the Trades

    Messages:
    1,487
    Location:
    Alaska
    You might be able to use a tube with one end by where you think the noise is coming from and the other end by your ear and see if that works.

    If it is coming from the white cam it could have started with the black cam that the white cam screws on to, or the gear that drives the black cam that is driven by the motor.

    It could be that the black cam's little locking ridge that locks the white cam in place has worn out and it is slipping.
  11. acrod

    acrod New Member

    Messages:
    14
    Location:
    tx
    Thanks for all the help so far, so what would you say are my best options right now? Is it worth it to try and fix?
  12. Akpsdvan

    Akpsdvan In the Trades

    Messages:
    1,487
    Location:
    Alaska
    Just did a rebuild.
    The main motor needed to be replaced, 125.0
    then the cage seal assembly 120.0
    black cam 20.00
    time spent working on changing of the parts, and the time spent on what was making it stop to before the backwash and before the brine draw...

    Your time has a $$$ to it, be it 25.00 or more...

    It could be a simple fix, then again it could run close to the 650 for a New 9100 SXT to take its place...
  13. acrod

    acrod New Member

    Messages:
    14
    Location:
    tx
    very true about what my time is worth. It's just so frustrating when you have no idea what the problem is.
  14. Akpsdvan

    Akpsdvan In the Trades

    Messages:
    1,487
    Location:
    Alaska
    Don't I know it, thought that the last one that I danced with would be straight forward and turned into FUBAR.

    Most of the time it is simple, but then there are times ....

    What you might look at doing is staying with a twin set up, but find a dealer that will give some kind of trade on what you have for a new 9100 with the SXT control, I put this on the table mainly because the Fleck 8500 old or new is on the way out, there will be a day soon that the parts will no longer be around.
Similar Threads: Problems fleck
Forum Title Date
Water Softener Forum, problems, installation and r Possible new problems on recently manufactured Fleck 7000 valves Feb 25, 2013
Water Softener Forum, problems, installation and r New home to me - Problems with Autotrol softener - salty water Oct 14, 2014
Water Softener Forum, problems, installation and r 7 year old softener problems Jul 20, 2014
Water Softener Forum, problems, installation and r Culligan Super S problems Jan 14, 2014
Water Softener Forum, problems, installation and r rain soft problems Nov 19, 2013

Share This Page