Problem with reverse osmosis filter

Discussion in 'Plumbing Forum, Professional & DIY Advice' started by Stonkey, Oct 9, 2010.

  1. Stonkey

    Stonkey New Member

    Joined:
    Oct 9, 2010
    Location:
    NY, USA
    My reverse osmosis filter is having some trouble. I am not getting any water flow from it whatsoever.

    I changed the small flavor filter, air tank, flow regulator on the waste line, all three initial stage filters, and the reverse osmosis element. Basically the only thing that I did not replace was a short, silver cylinder that has 4 tubes on it. I don't know what that is. I know that the water line to the filter is good, and I can even hear a trickle from the waste line, but I get no water to the taps.

    Anyone have any ideas what might be the problem? What other information do you need? And what pressure should I keep the tank at? I've been playing around with various pressures, but nothing seems to work.
     
  2. hj

    hj Moderator & Master Plumber Staff Member

    Joined:
    Aug 31, 2004
    Occupation:
    Plumber
    Location:
    Cave Creek, Arizona
    The "thing" with 4 tubes on it may be the pressure regulator, which determines whether the unit has to produce water or not. It could be defective, or you could have too much air in the tank so the regulator thinks it is full already. If you get a trickle down the drain, it should be making water.
     
  3. Sponsor

    Sponsor Paid Advertisement

     
  4. Stonkey

    Stonkey New Member

    Joined:
    Oct 9, 2010
    Location:
    NY, USA
    While I look into getting a new regulator, can you tell me what is a good pressure to keep the tank at?
     
Similar Threads: Problem reverse
Forum Title Date
Plumbing Forum, Professional & DIY Advice Hansgrohe 04233 shower control valve problem Today at 7:40 AM
Plumbing Forum, Professional & DIY Advice Water hammer problem, I think? Tuesday at 12:28 PM
Plumbing Forum, Professional & DIY Advice Weird dishwasher problem Tuesday at 8:57 AM
Plumbing Forum, Professional & DIY Advice Age old problem.......humming pipes Apr 12, 2015
Plumbing Forum, Professional & DIY Advice Changing toilet -- ran into problem. Floor mount, Rear outlet Apr 5, 2015

Share This Page