problem with kenmore ultra 800 water softener

Discussion in 'Water Softener Forum, problems, installation and r' started by David Cupp, Mar 7, 2011.

  1. David Cupp

    David Cupp New Member

    Messages:
    1
    Location:
    Bedford, TX
    Hi Terry, I was reading about a fella that had a similar problem with his kenmore ultra 800 water softener in that the water doesn't completely drain and the water in his house tastes very salty. you had a nimation to go to and i find i cant pull it up now. I've had it for several years [5+] and have never had any service done as it's been working fine until just the past month. I'm 70 and can do some things mechanically, I replaced it myself from an older unit, and have had no problems. I'm on soc. sec. and need to save money. do you have some instructions that i could use to get my softener running right again? thank you for your time. David
  2. mialynette2003

    mialynette2003 Member

    Messages:
    738
    Location:
    Ocala, Florida
Similar Threads: problem kenmore
Forum Title Date
Water Softener Forum, problems, installation and r Kenmore water softener problem; repair or replace? Feb 5, 2013
Water Softener Forum, problems, installation and r Problems with water softener, Kenmore Dec 22, 2012
Water Softener Forum, problems, installation and r Kenmore Softener Problems Jun 2, 2011
Water Softener Forum, problems, installation and r Kenmore Intellisoft 350 problems Aug 29, 2010
Water Softener Forum, problems, installation and r New home to me - Problems with Autotrol softener - salty water Oct 14, 2014

Share This Page