Pressure switch cycles on and off rapidly

Discussion in 'Pumps and Tanks Well Forum & Blog' started by JMTFARMS, Sep 20, 2013.

  1. JMTFARMS

    JMTFARMS New Member

    Messages:
    10
    Location:
    Missouri
    Pressure switch is cycling on and off rapidly. I thought there was a blockage between switch and pressure tank but cannot find any. I removed a pressure relief valve and left pipe open before pressure tank and have some water flow, but the switch still cycles on and off. Tried a different switch and had same result.

    Pressure switch is plumbed into a check valve (switch is on the pressure tank side of the check valve, check valve is installed in the correct direction). Could there be a malfunction in the check valve that is blocking flow after the pressure switch?

    Pump has a 2hp motor and according to the well cap is pumping 25 gpm.

    Thanks in advance for any replies.
  2. DonL

    DonL Jack of all trades

    Messages:
    3,812
    Location:
    Houston, TX
    Your water tank may be waterlogged.


    Good Luck.
  3. LLigetfa

    LLigetfa DIYer, not in the trades

    Messages:
    3,826
    Location:
    NW Ontario, Canada
    You should not have a topside checkvalve unless that checkvalve is part of an airmaker (snifter). If there is a lot of iron in your water then it is likely that the air precipitated the iron and the line is now constricted.
  4. JMTFARMS

    JMTFARMS New Member

    Messages:
    10
    Location:
    Missouri
    Tank is not waterlogged. Tank and system was empty and switch started cycling very rapidly. On off in one second or maybe even less. Switch still cycles with an open 11/4" pipe between switch and pressure tank.

    There is a lot of iron in the water and there is some deposits on inside of pipe, but I don't think there is enough deposits to cause a restriction. I do have some flow from the open pipe when the switch cycles. It is hard to tell how much flow because it surges as the switch cycles. Open pipe is less than 2 feet from check valve/switch with one 90 in between. I think a iron deposit clog in the 90 would have cleared when the pump and switch cycle.

    There was an iron filter on the system. The filter has been removed and a 1" hydro charger that was located before the check valve/pressure switch has been removed. There is now 11/4" line from the pump to the pressure tank. I think that the only thing that can be causing a restriction is the check valve. The pressure switch is plumbed into a port on the check valve. If something is loose or wrong with the check valve could it cause a restriction "downstream" of the pressure switch?

    The check valve can be removed by breaking loose two long time stuck unions. I tried some but could not budge them. I was hoping someone could tell me if my thinking was sound before I really try hard to get to the check valve. If anyone has any other ideas or anything else I should try I would appreciate it.

    Also is there any tricks to break loose the unions and fittings to get at the check valve? Will heat work? Oil? Any advice would be great. Thanks.
  5. traveller

    traveller Member

    Messages:
    44
    Location:
    British Columbia
    How far, in piping, is the pressure switch from the tank? Perhaps you could post a photo of the pump and tank setup.
  6. JMTFARMS

    JMTFARMS New Member

    Messages:
    10
    Location:
    Missouri
    Tank is about 3 feet from check valve/pressure switch. Pictures will have to wait till tomorrow. Thanks.
  7. LLigetfa

    LLigetfa DIYer, not in the trades

    Messages:
    3,826
    Location:
    NW Ontario, Canada
    I still say your line is restricted. If it is as rusted as you say then just take a sawzall to it and put in all new. Make sure the sense line goes close to the tank.
  8. traveller

    traveller Member

    Messages:
    44
    Location:
    British Columbia
    And this is a 2 hp submersible, correct?
  9. JMTFARMS

    JMTFARMS New Member

    Messages:
    10
    Location:
    Missouri
    Yes, 2 hp submersible, 11/4" pipe. I do not know how old it is, but I do know it has not been pulled for over 20 years. It also makes a lot of noise when running. Noise was greatly reduced when I removed the hydro charger, but it is still louder than any other pump/system we have. Pump control box also hums noticeably when it runs now. Pump seems to still be pumping good when I bypass pressure switch.

    And Yes the sawzall will probably end up being the tool to solve the problem. But, who knows where I will stop if I start putting in everything new.
  10. JMTFARMS

    JMTFARMS New Member

    Messages:
    10
    Location:
    Missouri
    Check valve was bad. Seal/plunger had broken loose and was creating a restriction. Thanks for your help.
  11. DonL

    DonL Jack of all trades

    Messages:
    3,812
    Location:
    Houston, TX

    Nice Job.


    Enjoy.
  12. rreith

    rreith New Member

    Messages:
    5
    Location:
    michigan
    Im having same problem with the starts and stops of pump. understand it could be a check valve or snifter? where are those located? thanks for any help. ive cut power to the pump temp. because im worried it will burn out if the starts and stops continue.
  13. LLigetfa

    LLigetfa DIYer, not in the trades

    Messages:
    3,826
    Location:
    NW Ontario, Canada
    You should start a new thread and not hijack this one.
  14. DonL

    DonL Jack of all trades

    Messages:
    3,812
    Location:
    Houston, TX
Similar Threads: Pressure switch
Forum Title Date
Pumps and Tanks Well Forum & Blog burned out pressure switch Sunday at 5:08 AM
Pumps and Tanks Well Forum & Blog Information on Distance between Pump Pressure Switch and Pressure Tank Jun 16, 2014
Pumps and Tanks Well Forum & Blog Square D pressure switch 9013FSG 2 Jun 3, 2014
Pumps and Tanks Well Forum & Blog Pressure Switch and the Jet Pump-They hate each other May 15, 2014
Pumps and Tanks Well Forum & Blog VFD pump with standard pressure switch? May 12, 2014

Share This Page