No Soft Water

Discussion in 'Plumbing Forum, Professional & DIY Advice' started by sbcoach, May 5, 2007.

  1. sbcoach

    sbcoach New Member

    May 3, 2007
    I have a Kenmore water softener that was run out of salt. Not a new thing. This time after refilling the salt and regenerating a few days there still is no soft water. Everything seems to be working correctly in the regeneration cycle but still no soft water. Ideas??
  2. kordts

    kordts In the Trades

    Oct 15, 2005
    industrial service plumbing foreman
    exurban Chicago
    Call Sears, if it's still under warranty. I myself use an independant treatment guy to test water and design the systems. Your salt setting may be too low. It may need to be set to regenerate more often.
  3. Sponsor

    Sponsor Paid Advertisement

  4. SteveW

    SteveW DIY Senior Member

    Feb 11, 2005
    Omaha, NE
    You probably have a water heater full of hard water. It will take a while to refill with soft water.
  5. Gary Slusser

    Gary Slusser That's all folks!

    Aug 31, 2004
    Wherever I park the motorhome.
    Is the water in the brine tank higher than normal?

    Is there water running to drain in a regeneration?

    Check the operation and troubleshooting sections here:
Similar Threads: Soft Water
Forum Title Date
Plumbing Forum, Professional & DIY Advice Water softener drain from sink stack? Thursday at 7:37 AM
Plumbing Forum, Professional & DIY Advice Estimate for installing water softner loop May 12, 2015
Plumbing Forum, Professional & DIY Advice Quick question about water softener. Brine tank is soapy. Is that normal? (with picture) Oct 18, 2014
Plumbing Forum, Professional & DIY Advice Water softener installation problem Jul 18, 2014
Plumbing Forum, Professional & DIY Advice Water Softener Drain Line Question Jul 11, 2014

Share This Page