No cold water coming from my single handle Pfister lavatory faucet

Discussion in 'Plumbing Forum, Professional & DIY Advice, Tips & ' started by anglii, Jun 7, 2011.

  1. anglii

    anglii New Member

    Messages:
    3
    Location:
    Alberta Canada
    We've had this Pfister T42-YP0 single handle faucet for about a year and it worked just fine until we added two compression fitting shut-off valves to the water line. Now the cold water just trickles (hot has less pressure than before but acceptable).

    [​IMG]

    I accidentally got some drywall mud/depris into the valves before the braided hoses were attached. Can this be the problem or what else can it be? Any help would be appreciated.
    Last edited: Jun 7, 2011
  2. hj

    hj Moderator & Master Plumber Staff Member

    Messages:
    26,641
    Location:
    Cave Creek, Arizona
    Are you sure you did not "kink" the supply lines between the valve and the faucet? "Drywall dust" would have been flushed out IMMEDIATELY when the water was turned on. If the aerator was plugged, you would get the same amount of water from both sides. Were these the type of valve which you screwed on to the original valves between the valve and supply line? If so, THAT may be where the obstruction is. Ihave a fairly low opinion of that type of valve.
  3. anglii

    anglii New Member

    Messages:
    3
    Location:
    Alberta Canada
    Thanks hj for the super fast reply!

    The valves are sharkbites. Was told that all the plumbers where using them now but from what I'm gathering they aren't a permanent solution and may eventually leak. Do these valves have known issues that could cause the cold water to trickle? Should they be replaced?

    [​IMG]
    Last edited: Jun 7, 2011
  4. hj

    hj Moderator & Master Plumber Staff Member

    Messages:
    26,641
    Location:
    Cave Creek, Arizona
    "Real plumbers" do NOT use them, for a few reasons, cost being one of them, but they should not cause your symtoms, assuming you did NOT crush the "stabilizer sleeve" which is used with plastic lines.
  5. anglii

    anglii New Member

    Messages:
    3
    Location:
    Alberta Canada
    hj help!

    So I disconnected the cold water supply line from the faucet to the shut-off valve and gauging from the water dripping down my face after I opened the shark valve, the valve works just fine. I did notice a chunk of debris in the line and removed it but now I'm worried that more debris has been pushed further along the line where I can't reach it. Any suggestions?

    I had to get a neighborhood kid to undo the line for me because hubby isn't here for another week and I didn't have the strength, so don't want to reconnect until all options have been explored.

    I took an air hose and blew into the faucet opening (where the water normally comes out) but that didn't work at all. The air just blew back out of the same opening (path of least resistance) :(
    Last edited: Jun 9, 2011
Similar Threads: cold water
Forum Title Date
Plumbing Forum, Professional & DIY Advice, Tips & Can anyone explain this cold water shutoff valve phenomena Jul 30, 2014
Plumbing Forum, Professional & DIY Advice, Tips & Hot/Cold Water crossover Jun 28, 2014
Plumbing Forum, Professional & DIY Advice, Tips & Low Cold Water Pressure in Entire House Jun 18, 2014
Plumbing Forum, Professional & DIY Advice, Tips & Hot water coming out cold faucet all over hotel May 27, 2014
Plumbing Forum, Professional & DIY Advice, Tips & Hot water at cold tap: questions about recirc pump, sprinklers, and check valves May 5, 2014

Share This Page