Need help with pressure switch

Discussion in 'Pumps and Tanks Well Forum & Blog' started by dmd45, Apr 13, 2006.

  1. dmd45

    dmd45 New Member

    Messages:
    5
    Every 2-3 months my pump pressure switch dies and has to be replaced.This has happened 3 times now.Is this a sign of a pump going bad or a short in the system.Thanks
  2. Cass

    Cass Plumber

    Messages:
    5,980
    Location:
    Ohio
    Low voltage perhaps, How far from the electric pannel is the switch? Also look for a bad connection anywhere from the breaker/pannel connection to the switch.
  3. dmd45

    dmd45 New Member

    Messages:
    5
    Also I noticed since this problem started,when you run water at a faucet the pressure rises and drops as the switch turns on and off.Pressure before this problem was pretty steady.
  4. dmd45

    dmd45 New Member

    Messages:
    5
    The box is about 50ft. from the switch.When the switch goes bad there is power coming in to the switch but none going out.
  5. Cass

    Cass Plumber

    Messages:
    5,980
    Location:
    Ohio
    Check for a bad connection at all points and check the voltage. Check the breaker it can look good but when pulled and inspected closely it may be burned. Check all wire nut connections. What brand is the electric pannel and is it breakers or fuses?
    Last edited: Apr 13, 2006
  6. dmd45

    dmd45 New Member

    Messages:
    5
    Not sure I am at work right now,will check later.Thanks
  7. speedbump

    speedbump Previous member

    Messages:
    4,540
    Location:
    Riverview, Fl.
    Your tank is waterlogged and is causing the pump motor to cycle rapidly. If you let it persist the motor is next to go.

    bob...
  8. Bob NH

    Bob NH In the Trades

    Messages:
    3,317
    Location:
    New Hampshire
    Switches should last for years. They will fail electrically if the pump is started and stopped with very short cycles. It is also possible to fail a switch if the pressure is exceeded. Please describe your system and its operation so we can try to diagnose the problem. The questions are in the order I thought of them without any particular order as to the logic of diagnosing the problem.

    1. Do you have a control valve in the pump/pressure system such as a Cycle Stop Valve or at Smart Tee? If you have such a device, do you have a pressure gauge before and after the device?

    2. What are the pump-start and pump-stop settings on your pressure switch? Have you verified the settings with a good gauge?

    3. Do you have a working pressure gauge? Check it by running all of the water out of the tank with the pump off. I should read zero.

    4. What size pressure tank do you have? Is it a bladder tank or a non-bladder tank?

    5. If you drain water to the point when the pump starts and then turn the water off, how long does the pump run before shutoff?

    6. Do you have a variable speed or constant-pressure pump system?

    7. What is the precharge pressure in your tank when the water has been drained out of it with the pump turned off? It should be 2psi less than the pump-start setting on your pressure switch.

    8. What kind of pump do you have? Submersible? Shallow well jet? Deep well jet?

    9. What are the characteristics of the failed switches? Contacts destroyed? Mechanism not operating? When there is no power through the switch, can you see whether the contacts are in physical contact? Do you have a meter to measure voltage or resistance?

    10. If you run a little water so the pump comes on and shuts off while you are running the water how long does the pump stay on when it turns on? What is the pressure reading while it is pumping?
  9. dmd45

    dmd45 New Member

    Messages:
    5
    I will try to answer these questions in more detail later when I am home.The ones I know are--It is a 30/50 switch,when it dies there is no sign of damage,there is a pressure gauge that goes to 0 when there is no pressure,It is a bladder tank but not sure of size,The pump is a submersible,Thanks
  10. Pumpman

    Pumpman Pump Sales

    Messages:
    191
    Location:
    So. Cal
    I agree with Speedbump. It sounds like the tank is waterlogged. I'm sure if you look at the faces of the contacts, you'll see pitting, which happens when a pump cycles rapidly.
    Ron
  11. jadnashua

    jadnashua Retired Defense Industry Engineer xxx

    Messages:
    22,017
    Location:
    New England
    Sounds like the tank is shot (I fully agree with the others). Turn the power off to the pump. Verify you have pressure on the gauge. Open a faucet. If it immediately drops to zero, that is verification. Now it is (unlikely but possible) that you just lost air pressure, but the bladder is probably gone, so it is new tank time. If you get water out of the Schrader valve on the tank, then that just is another confirmation of a shot tank.

    Now, it is possible that you don't have a bladder tank. Then, you may have a problem with the air admittance valve (did I get that name right?). But, they are not as common as bladder tanks anymore.
Similar Threads: Need help
Forum Title Date
Pumps and Tanks Well Forum & Blog Desperately need help with Well Pump no pressure issue Tuesday at 9:00 AM
Pumps and Tanks Well Forum & Blog Existing Well, need a new well??? Help lol Sep 3, 2014
Pumps and Tanks Well Forum & Blog Need exterior sump pump help Jun 23, 2014
Pumps and Tanks Well Forum & Blog Need help with well Jun 10, 2014
Pumps and Tanks Well Forum & Blog Need help! - Low pressure in sprinkler system - The well to blame? Solutions? Jun 8, 2014

Share This Page