"Need Help ASAP", Thank you! Pressure Loop Problem with Moentrol

Discussion in 'Shower & Bathtub Forum & Blog' started by JZavoda, Apr 13, 2007.

  1. JZavoda

    JZavoda New Member

    Joined:
    Apr 13, 2007
    I have just installed a Moentrol off of a pressure loop which leads to four body spray jets, a rain shower head, and seperate body spray system. The problem I am facing is that upon installing this unit I now have turned on the water main and I am not getting any water through the lines. Could it be possible that a lever is on backward on my Moentrol or that a valve is upside down blocking the flow of the water? Any troubleshooting help would be appreciated. Thank you for your time. Jeff
     
  2. jadnashua

    jadnashua Retired Defense Industry Engineer xxx

    Joined:
    Sep 2, 2004
    Occupation:
    Retired Systems engineer for defense industry.
    Location:
    New England
    Some valves have integral service stops...you sure all of them are on? Also, if you only turned on one supply, the pressure balance feature would block flow. You need both hot and cold turned on.
     
  3. Sponsor

    Sponsor Paid Advertisement

     
Similar Threads: Need Help
Forum Title Date
Shower & Bathtub Forum & Blog Cement board/drywall dilemma, need help Monday at 1:46 PM
Shower & Bathtub Forum & Blog Need help identifying Tub valve Jul 12, 2015
Shower & Bathtub Forum & Blog Old man needs help with tub faucet leak May 29, 2015
Shower & Bathtub Forum & Blog Need help identifying this faucet and stem Apr 7, 2015
Shower & Bathtub Forum & Blog Need help installing new shower faucet Feb 5, 2015

Share This Page