Mobile Home Toilet Still Runs with New Flapper Installed

Discussion in 'Toilet Forum discussions' started by kailor, Jan 5, 2011.

  1. kailor

    kailor New Member

    Messages:
    22
    Location:
    Huntsville, Alabama
    I have a mobile home toilet that still runs even after installing a new flapper. If I press down on the new flapper the water quits running into the bowl. I've cleaned the edge where the flapper rests. How can I fix this. Is there some kind of replacement part?
  2. Gary Swart

    Gary Swart In the Trades

    Messages:
    7,308
    Location:
    Yakima WA
    You might supply a bit more information. Make and model of toilet and make and model of the flapper would be a good start.
  3. kailor

    kailor New Member

    Messages:
    22
    Location:
    Huntsville, Alabama
    Thanks Gary. Can I find this information underneath the tank lid?
  4. jadnashua

    jadnashua Retired Defense Industry Engineer xxx

    Messages:
    21,822
    Location:
    New England
    Not all generic flapper valves will fit all toilets. But, the first thing to check is that there is enough slack in the chain, and that there isn't too much and it is caught underneath. On some, they have hooks and a round sleeve for those that don't have hooks. If you have hooks and you used the sleeve, you need to cut out the sleeve and only use the hooks.
Similar Threads: Mobile Home
Forum Title Date
Toilet Forum discussions I need help with a Flushometer toilet? May 8, 2014
Toilet Forum discussions Small Flushometer toilet 14" rough? May 7, 2014
Toilet Forum discussions Flushometer not clearing bowl Apr 24, 2014
Toilet Forum discussions Toto toilet bought through Home Depot Jul 31, 2013
Toilet Forum discussions A toto toilet for an old home with many kids Jul 19, 2013

Share This Page