Messed with new pressure switch.....

Discussion in 'Pumps and Tanks Well Forum & Blog' started by scarab138, Nov 23, 2008.

  1. scarab138

    scarab138 New Member

    Messages:
    2
    Hi,
    I had my pressure switch replaced this week. Seemed to fix pressure problems, until my son tried to do laundry. He said that the water just stopped, so he started messing with the new switch. He changed the pressure settings, randomly tightening and loosening the controls. Now we have no water and I am unsure how to get it back on. Please help. :confused:
  2. Gary Slusser

    Gary Slusser That's all folks!

    I think you have a pump problem or more likely the well is running dry after high water usage.

    Call a pump guy or well driller to readjust the switch and check out the system. They may have to pull the pump.

    Or, read the sticky posts at the top of this forum if you want to try adjusting the switch yourselves.
    Last edited: Nov 23, 2008
  3. scarab138

    scarab138 New Member

    Messages:
    2
    Thanks for the reply. I gave the well a few days, turned the power back on, and the pressure shot up. Scared the hell out of me because it shot up to 90psi!!!! I looked at the old switch, and adjusted the new one to compare with the old one. Seems to be okay now (65 psi), but it has ran dry once since. I am waaaaayyy up in The Great White North (Canada), and I was wondering if freezing temperatures could cause the well to fill slower?
  4. Gary Slusser

    Gary Slusser That's all folks!

    Yes it can because when the ground is frozen and water can't percolate down through the earth into the water table.
Similar Threads: Messed pressure
Forum Title Date
Pumps and Tanks Well Forum & Blog Desperately need help with Well Pump no pressure issue Yesterday at 9:00 AM
Pumps and Tanks Well Forum & Blog Question on new pressure tank install.. outside barn hydrant Saturday at 9:24 AM
Pumps and Tanks Well Forum & Blog jet pump pressure switch question Thursday at 7:09 PM
Pumps and Tanks Well Forum & Blog Loud thud/slapping noise after well pressure tank cut off at 60 psi Thursday at 8:50 AM
Pumps and Tanks Well Forum & Blog well water stops, but pressure gauge normal Sep 9, 2014

Share This Page