Luxaire Furnace

Discussion in 'HVAC Heating & Cooling' started by Fudog, Oct 20, 2013.

  1. Fudog

    Fudog New Member

    Messages:
    28
    Just turned furnace on for the year for heat and it will not work. Worked fine at the end of winter. Cleaned the flame sensor as I do every year and nothing. Igniter will not glow. Any suggestions? Thanks
  2. DonL

    DonL Jack of all trades Master of one

    Messages:
    4,127
    Location:
    Houston, TX
    Are you getting power ?

    Maybe a safety switch is not closed properly. Or your T-Stat is not calling for heat.


    Good Luck.
  3. dj2

    dj2 Member

    Messages:
    411
    Location:
    California
    You need an accurate diagnosis, something that can't be done from here (in front of the computer).

    1. Gas supply: you mentioned 'flame', so you have a gas unit. Is gas on? Is gas reaching the gas valve? Is gas coming out of the gas valve? Is the orifice clean? - you need a plumber to check and repair gas valves (not a DIY project).

    2. The igniter could be out.
  4. Fudog

    Fudog New Member

    Messages:
    28
    This is a gas furnace. How do I check the spiral glow igniter?
  5. DonL

    DonL Jack of all trades Master of one

    Messages:
    4,127
    Location:
    Houston, TX

    With a OHM meter. After you turn power OFF.

    They are very fragile, do not touch it.

    If it is open the the gas valve will not turn on.


    Good Luck.
  6. Fudog

    Fudog New Member

    Messages:
    28
    What should i get for an ohm reading to determine a bad one?
  7. Fudog

    Fudog New Member

    Messages:
    28
    Took an Ohm reading and showing 284 and have 112v at the plug in.
  8. DonL

    DonL Jack of all trades Master of one

    Messages:
    4,127
    Location:
    Houston, TX

    A bad one will be open.

    A good one will give you a reading on R X 100. Depends on the model.
  9. Fudog

    Fudog New Member

    Messages:
    28
    None of the rollout limit switches are tripped. There were 3 of them. All had 27-28 volts on each side.
  10. Fudog

    Fudog New Member

    Messages:
    28
    Induced draft blower is working. Would the spiral igniter have an ohm reading stamped on it? 284 is what i am showing.
  11. DonL

    DonL Jack of all trades Master of one

    Messages:
    4,127
    Location:
    Houston, TX

    What is your model number ? The manual may tell you what the resistance should be.

    If it had 112V across it and it was not glowing then it is bad.

    The cold resistance sounds a bit high to me.


    Be careful playing with Gas.
  12. Fudog

    Fudog New Member

    Messages:
    28
    Had the HVAC Repairman come yesterday and everything checked out fine with the Diagnosis being [vent motor clogged up with stink bugs] We have had alot of them in WV and he said he had done the same thing the day before on another customers furnace. I guess since the weather has started to cool down the stink bugs are trying to get inside anywhere they can thru furnace vents and dryer vents. I just wanted to let everyone know what the diagnosis was and I appreciate the help as I wanted to fix this myself. I just came home from work. I drive Tractor trailer at night and it is time to sign off and go to bed. Thanks!
  13. DonL

    DonL Jack of all trades Master of one

    Messages:
    4,127
    Location:
    Houston, TX
    Thanks for the report.

    Sounds like all safety systems were working.


    That is a good thing.
Similar Threads: Luxaire Furnace
Forum Title Date
HVAC Heating & Cooling Luxaire Furnace Apr 28, 2008
HVAC Heating & Cooling electric forced air furnace will not come on Jun 8, 2014
HVAC Heating & Cooling Gooodman Furnace May 7, 2014
HVAC Heating & Cooling Bryant Furnace 925s Apr 30, 2014
HVAC Heating & Cooling Electric furnace blower motor doesn't turn on once in a while Mar 7, 2014

Share This Page