Lost water pressure in tub/shower

Discussion in 'Shower & Bathtub Forum & Blog' started by phillaube, Jul 4, 2008.

  1. phillaube

    phillaube New Member

    Joined:
    Jul 4, 2008
    Occupation:
    CPA
    Location:
    Southeast Ohio
    I'm having trouble finding a solution to my problem. I've lost most of the pressure in my upstairs tub/shower. This is an old (maybe price pfister?) setup with two handles, separate spigot/faucet and shower head above - circa 1960. Tub/shower diverter is in the spigot. Flow is slow everywhere in the tub but fine in the sink and toilet. I've removed spigot and flow was still slow (how I know the diverter is there). I've pulled the stems - which I replaced last year to fix a drip - and everything looks as installed. Washers look good and intact. I've tried shutting off the water a few times to flush it, but nothing. Our water is very hard and I'm sure it's either a piece of limescale that broke loose somewhere or something similar. But I can't seem to get to it. Any suggestions? This is of course the shower my wife uses and her patience is running low.

    Thanks,
     
Similar Threads: Lost water
Forum Title Date
Shower & Bathtub Forum & Blog Water Noise in Bathroom Jun 2, 2015
Shower & Bathtub Forum & Blog Thermostatic mixing valve - hot water only? May 26, 2015
Shower & Bathtub Forum & Blog Replaced Delta Shower/Tub Cartridge Now Water Pressure Is Worse! May 19, 2015
Shower & Bathtub Forum & Blog Slope to drain water from apron into tub May 17, 2015
Shower & Bathtub Forum & Blog Water leaking from back of dome nut (Delta single tub faucet) Apr 19, 2015

Share This Page