Losing prime on my shallow well

Discussion in 'Pumps and Tanks Well Forum & Blog' started by Siestabob, Feb 22, 2008.

  1. Siestabob

    Siestabob New Member

    Joined:
    Dec 19, 2007
    I have a shallow well with 4 points at about 17 ft. I have a check valve right before the intake with a filter after outflow. I turn my centrifugal pump on and let it run for about 5 mins. and get a good 35 gpm. When I turn it off and keep it off for several hours it takes 5 mins again to get the water start flowing again. I need to have immedate flow don't I in order to run sprinklers?

    Help
    Bob.
     
  2. speedbump

    speedbump Previous member

    Joined:
    Jul 15, 2005
    Occupation:
    Water well and pump tech.
    Location:
    Riverview, Fl.
    Move the check valve to the furthest possible point from the pump. Like where all the wells tee together.

    bob...
     
  3. Sponsor

    Sponsor Paid Advertisement

     
  4. Siestabob

    Siestabob New Member

    Joined:
    Dec 19, 2007
    Thanks for the quick response. I will try that today. Can I have two check valves?
    Thanks
    Bob
     
  5. speedbump

    speedbump Previous member

    Joined:
    Jul 15, 2005
    Occupation:
    Water well and pump tech.
    Location:
    Riverview, Fl.
    Nope, bad idea, its the one at the pump that is allowing air to get into the piping. With the one at the wells only, the entire suction line will stay pressurized.

    bob...
     
  6. Siestabob

    Siestabob New Member

    Joined:
    Dec 19, 2007
    Thanks again for the answer. I will put the check valve underground near the connection point of all the wells.
    Bob
     
Similar Threads: Losing prime
Forum Title Date
Pumps and Tanks Well Forum & Blog Jet Pump losing prime with new foot valve after sitting 4 -5 hrs Aug 12, 2015
Pumps and Tanks Well Forum & Blog Pump losing prime? Jul 1, 2015
Pumps and Tanks Well Forum & Blog Please help. Losing pressure. Not prime. Jun 29, 2014
Pumps and Tanks Well Forum & Blog Pump Losing Prime Quickly Nov 27, 2012
Pumps and Tanks Well Forum & Blog Jet Pump losing prime whgile running Jan 12, 2011

Share This Page