Lazy Flush

Discussion in 'Toilet Forum discussions' started by gotzoom, Mar 23, 2010.

  1. gotzoom

    gotzoom New Member

    Joined:
    Mar 23, 2010
    Location:
    ND
    Hi All,

    New here and have an issue with my toilet. I noticed all of a sudden a lazy flush occuring so I did all of the basic test...Adjusting flapper, checking fill line, adjusting the ball..

    Here is the kicker...

    After minor adjustments to ball and water level fill I have tested/flushed the toilet with the tank lid off, I get a nice strong flush and correct water fill, but once I put the tank lid back on...Lazy flush all over again.

    I have checked for clearence to make sure nothing is touching and so forth but I cannot figure this one out.

    Help??
     
  2. hj

    hj Moderator & Master Plumber Staff Member

    Joined:
    Aug 31, 2004
    Occupation:
    Plumber
    Location:
    Cave Creek, Arizona
    Check the trip lever. It may be hitting the cover before it lifts the flapper high enough to maintain a good flush. IF so, shorten the chain on the flapper.
     
  3. Sponsor

    Sponsor Paid Advertisement

     
Similar Threads: Lazy Flush
Forum Title Date
Toilet Forum discussions Toto Soiree Lazy Flush Jan 7, 2013
Toilet Forum discussions Muratic Acid for lazy flush Oct 23, 2004
Toilet Forum discussions Toto ST743S leaks when flushed Saturday at 2:06 PM
Toilet Forum discussions Dual Flush Low Flow Toilet Jul 22, 2015
Toilet Forum discussions Toto CST854; replaced flapper but water keeps running on after flushing Jul 16, 2015

Share This Page