Kinetico water softener

Discussion in 'Water Softener Forum, problems, installation and r' started by snifferpro, Apr 10, 2013.

  1. snifferpro

    snifferpro New Member

    Messages:
    15
    Location:
    Phoenix, AZ
    I have a model 50 Kinetico system.

    Just yesterday I noticed i'm no longer gettting soft water.

    I used a test strip to check and it's definitely hard.

    I then ran the water long enough for the system to switch
    tanks and checked with a strip again. No soft water.

    I had a similar issue 2 years ago. In that case, I would get
    soft water only from one tank. When it switched to the other
    I would get hard water. Switch again and I would get soft
    water. Turned out that the tube that goes down the center of the
    tank had snapped a couple of the tines in the tank that would give
    hard water. Had both tanks replaced and all was fine.

    Now, I get hard water from both tanks.

    Is there something easy I can check to see why i'm not getting
    soft water?

    Thanks
  2. Gary Slusser

    Gary Slusser That's all folks!

    Is there salt in the tank?

    Has it been suing salt?

    Does it suck brine when in regeneration?
  3. snifferpro

    snifferpro New Member

    Messages:
    15
    Location:
    Phoenix, AZ
    There is definitely salt in the tank.

    I just noticed this problem yesterday so I don't know if it sucks brine. It has been using salt as I added some just over a week
    ago. As for sucking brine, I'll have to force a tank switch to check.

    I will keep track of the salt usage.
  4. mialynette2003

    mialynette2003 Member

    Messages:
    731
    Location:
    Ocala, Florida
    If you put the unit into a brine/rinse cycle, you can disconnect the brine line from the valve and feel if it is drawing. If it is, switch to the other tank to see if it is drawing on that tank. There will be water coming out of the brine connection when you change tanks. If you have a draw on both tanks, check to see if it is metering by opening up a faucet inside the house and watch the no back pawl. You should see it ride up one tooth of the meter disc and drop into the slot of the next one. i have exploded views of the internal parts. If you need one, drop me an email ans I'll send it to you.
  5. snifferpro

    snifferpro New Member

    Messages:
    15
    Location:
    Phoenix, AZ
    I'm about to check it out now
  6. snifferpro

    snifferpro New Member

    Messages:
    15
    Location:
    Phoenix, AZ
    OK, I just regenerated twice. water is being sucked out of the tank and being replenished

    Couldn't tell if the pawl moved at all (these old eyes don't work as good as they used to.
Similar Threads: Kinetico water
Forum Title Date
Water Softener Forum, problems, installation and r Kinetico water softener and salty tasting water Aug 10, 2014
Water Softener Forum, problems, installation and r Kinetico Waterplant works on 1 side only Aug 4, 2014
Water Softener Forum, problems, installation and r Kinetico Model 60 Salt taste in house water May 20, 2014
Water Softener Forum, problems, installation and r Kinetico water softener problems Jul 27, 2013
Water Softener Forum, problems, installation and r Kinetico 2060 Water Softner Jan 4, 2013

Share This Page