kinetico model 60

Discussion in 'Water Softener Forum, problems, installation and r' started by ChadI, Nov 23, 2011.

  1. ChadI

    ChadI New Member

    Joined:
    Nov 23, 2011
    Location:
    florida
    I have a kinetico model 60 with duel black tanks. my problem is the screws stripped on the clear rubber top, that has the adjustment screw in the center. after using a type and dye kit it cracked the rubber part and stripped the black base of the water softener head/valve. Im looking for a model 60 head for parts. I cant find a dealer online anywhere to get parts. also tried the local dealer and they wont answer there phone. please let me know if you have any parts.
     
  2. mialynette2003

    mialynette2003 Member

    Joined:
    Nov 24, 2010
    Occupation:
    Owner of SWS Systems WWW.SWSSYSTEM.COM
    Location:
    Ocala, Florida
    I can get parts for you. E-mail me at affordablewtr@aol.com I will also send you a parts diagram to make sure you get the right parts.
     
  3. Sponsor

    Sponsor Paid Advertisement

     
Similar Threads: kinetico model
Forum Title Date
Water Softener Forum, problems, installation and r Kinetico - Model 51 - Will not draw brine Jun 11, 2015
Water Softener Forum, problems, installation and r Kinetico Model 60, 1 tank now very loud during brine rinse Mar 10, 2015
Water Softener Forum, problems, installation and r KINETICO Model 60 PAWL LAYOUT Sep 15, 2014
Water Softener Forum, problems, installation and r Kinetico Model 60 Toothed Disk Operation Sep 12, 2014
Water Softener Forum, problems, installation and r Kinetico Model 60 problem with manually turing disc to regen Sep 11, 2014

Share This Page