Kinetico K-60 is discharging constantly.

Discussion in 'Water Softener Forum, problems, installation and r' started by TinaB, Mar 18, 2012.

  1. TinaB

    TinaB New Member

    Messages:
    2
    Location:
    Baltimore
    Our Kinetico K60 is constantly discharging water (just a steady trickle). It is going through 40 lbs. of salt every few days. We have replaced the piston parts and the float assembly.
  2. chevy427

    chevy427 Banned

    Messages:
    174
    Location:
    USA
    How old is it? Tan or black tanks? Who is "we"? Did you disassemble it or did a local dealer? Did levels 2 and 3 separate? It could be a seal that is leaking through.
  3. mialynette2003

    mialynette2003 Member

    Messages:
    738
    Location:
    Ocala, Florida
    The drain seals may be bad. You would have to take the unit apart in order to replace them. If you need a parts breakdown, e-mail me @ affordablewtr@aol.com and I'll send then to you.
  4. TinaB

    TinaB New Member

    Messages:
    2
    Location:
    Baltimore
    The softener is old but not sure exactly how old. The tanks are tan. We means my husband. It wasn't regenerating on its own and he tore it apart and replaced some parts. It regenerates on its own now but there is a constant trickle and we are going through about 40 lbs of salt every 2 to 3 days. I am hoping he can fix it since it is a $150 service charge plus parts. My husband is extremely handy but the water trickle has him stumped. Thanks for all of your help.
  5. chevy427

    chevy427 Banned

    Messages:
    174
    Location:
    USA
    I wonder if you can take a sample of the dripping water and have it tested to see if it is hard or soft? That would help narrow the problem. Is it possible to do this?

    If it is hard, then you have a problem with the drain valve.

    If it is soft, there are any number of causes, some of which are relatively easy to fix.

    In the older units like yours, levels 2 and 3 were 'molded' together. If there is a small warp between the two, water will be short-cutting and seeping through or by-passing water ports. This would require this section to be replaced with separate levels (2 & 3).

    Is your household water pressure less than 20psi?

    Whatever you do, DON'T lubricate o-rings or seals with Vasoline or any other petroleum product.
Similar Threads: Kinetico K-60
Forum Title Date
Water Softener Forum, problems, installation and r Questions about installing a Kinetico K-60 Dec 1, 2013
Water Softener Forum, problems, installation and r Kinetico 60 Troubleshooting Wednesday at 9:44 PM
Water Softener Forum, problems, installation and r KINETICO Model 60 PAWL LAYOUT Monday at 11:14 AM
Water Softener Forum, problems, installation and r Kinetico Model 60 Toothed Disk Operation Sep 12, 2014
Water Softener Forum, problems, installation and r Kinetico Model 60 problem with manually turing disc to regen Sep 11, 2014

Share This Page