1. Billyg57

    Billyg57 New Member

    Messages:
    1
    Location:
    Ohio
    Center control switch etc.brine rinse,backwash water leaking from setting screw.Is there a gasket,washer or o-ring that could be bad?
  2. nhmaster3015

    nhmaster3015 Master Plumber

    Messages:
    836
    Location:
    The granite state
    could be, our Kinetico guy does not post here anymore though and I have not had enough of them apart to be able to say.
  3. Skip Wolverton

    Skip Wolverton In the Trades

    Messages:
    167
    Location:
    Ocala, Fl
    The plunger you push (actuator) to start a regen does have a o ring. If you push down on the actuator a couple times, that sometimes seats the o ring and it will stop leaking. If not, place unit on bypass, relieve the pressure and remove the 8 screws holding the clear cap on. Once the cap is off the unit, push down on the actuator and it will pop out. The o ring may stay in the clear cap. You may find a o ring at your local hardware store or a hrydraulic repair business.
Similar Threads: Kinetico
Forum Title Date
Water Softener Forum, problems, installation and r Kinetico Model 60 recharging more often and using more salt than it used to Tuesday at 7:51 AM
Water Softener Forum, problems, installation and r Maximum PSI intake for Kinetico 2175 Jul 9, 2014
Water Softener Forum, problems, installation and r Kinetico Model 60 Salt taste in house water May 20, 2014
Water Softener Forum, problems, installation and r "Big picture" of Kinetico process available? May 11, 2014
Water Softener Forum, problems, installation and r Kinetico Mach Series Potassium not drawing Apr 18, 2014

Share This Page