Kinetico 50 head assembly problem

Discussion in 'Water Softener Forum, problems, installation and r' started by Ace, Jun 14, 2010.

  1. Ace

    Ace New Member

    Messages:
    2
    Location:
    Florida
    I have a Kinetico 50 and I was having a problem with salt coming through my drinking water when the unit regenerated. This happened before and they came out and charged me a lot of money to pull a piece of glue out of the head. I am very mechanically inclined, so I decided to see if I could pull apart the head to see if there was anything caught up in it. I couldn't find anything so I cleaned it up and put it back together. I kept having flow through the line to the brine tank. I realized that something was missing. When I looked this morning I found 2 small blue balls on the ground where the unit is. I took the head in the house and I can't figure out for the life of me where they go. Of course finding a diagram online is a lost cause.
    Can someone tell me where the 2 balls go? I seen in one post that it said "The check balls are located in the main base. I have had them fall out of place while reassembling the head" But where in the main base do they go?
    Another thing.. On the black gear that goes in first, there is a black line on one side, and a white line on the other. Does that need to be lined up with anything while putting back in?
    Thank you
    Last edited: Jun 14, 2010
  2. nhmaster3015

    nhmaster3015 Master Plumber

    Messages:
    836
    Location:
    The granite state
    Sorry nobody has responded yet but we don't have anyone here anymore that can address Kinetico issues. I could PM you with a site and or name but PM's are still down.
  3. Skip Wolverton

    Skip Wolverton In the Trades

    Messages:
    167
    Location:
    Ocala, Fl
    The 2 blue balls are check balls for the brine draw and are located on the main base. I tried to attach a pic of where they are located. It says it's too big. Send me an e-mail and I'll send them if you need.
  4. Ace

    Ace New Member

    Messages:
    2
    Location:
    Florida
    Skip, thank you! I found the place where the 2 balls went. Now what's happening is when I use water, it looks like the white disk under the site glass starts to spin and them jumps back a tooth. I stood there for about ten minutes while it was going through the wash stage and it never moved. What could be the problem?
  5. Skip Wolverton

    Skip Wolverton In the Trades

    Messages:
    167
    Location:
    Ocala, Fl
    Ace,
    Send me an e-mail and I'll send some pics to be sure we are on the same page. affordablewtr@aol.
Similar Threads: Kinetico head
Forum Title Date
Water Softener Forum, problems, installation and r Who can service my Kinetico head (pistons)? Indy Kinetico dealer has exhausted me Oct 9, 2013
Water Softener Forum, problems, installation and r Won't stop regenerating! Kinetico 2100 FOD filter head Jan 17, 2013
Water Softener Forum, problems, installation and r Kinetico #60 replacement head? Aug 23, 2009
Water Softener Forum, problems, installation and r Kinetico softener head rebuild with pics Jun 9, 2009
Water Softener Forum, problems, installation and r Kinetico Model 60 recharging more often and using more salt than it used to Tuesday at 7:51 AM

Share This Page