kinetico 30 need help

Discussion in 'Water Softener Forum, problems, installation and r' started by mark andy, Sep 11, 2009.

  1. mark andy

    mark andy New Member

    Joined:
    Sep 11, 2009
    Location:
    ohio
    hi, the disk on the top brine rinse backwash will not move from the position i manually put it in. the water just runs and runs and runs from the line down into my drain... any help would be great. thank you.
     
  2. Gary Slusser

    Gary Slusser That's all folks!

    Joined:
    Aug 31, 2004
    Occupation:
    Retired
    Location:
    Wherever I park the motorhome.
    I would guess there is a blockage in the water powered part or something broken in the drive train causing it to not rotate and drive the gears. So you take it apart or call the local Kinetic dealer for service.

    In the mean time I'd put the softener in by pass to stop the continuous flow of water to drain.
     
  3. Sponsor

    Sponsor Paid Advertisement

     
Similar Threads: kinetico need
Forum Title Date
Water Softener Forum, problems, installation and r Kinetico Parts List Needed… Quadra-Flo Jul 7, 2015
Water Softener Forum, problems, installation and r Need a manual for a 20 year old model 60 KINETICO Sep 9, 2014
Water Softener Forum, problems, installation and r Rebuilt Kinetico 60 -- need drawings Mar 31, 2014
Water Softener Forum, problems, installation and r Kinetico 60, what do I need to rebuild? Jul 30, 2013
Water Softener Forum, problems, installation and r Do I need chlorine filter with Kinetico and city water? Jul 15, 2011

Share This Page