Kenmore Water Softener - Discharging via Overflow Line

Discussion in 'Water Softener Forum, problems, installation and r' started by pgdaboys, Jan 10, 2010.

  1. pgdaboys

    pgdaboys New Member

    Joined:
    Jan 10, 2010
    Location:
    Texas
    I have a Kenmore Deluxe Demand Water Softener that is approximately 12 years old. Lately, I've noticed that while the master bathtub is being filled, the water softener discharges water to the overflow drain. I don't know if this has just started occurring or perhaps I just never noticed before... at any rate, can anyone tell me if this normal or is it indicative of a problem that needs to be corrected? Thanks!
     
  2. nhmaster

    nhmaster Master Plumber

    Joined:
    Jul 30, 2008
    Occupation:
    Tech. Instructor
    Location:
    S. Maine
    No, that ain't normal and indicates a problem in the valve head.
     
  3. Sponsor

    Sponsor Paid Advertisement

     
  4. Akpsdvan

    Akpsdvan In the Trades

    Joined:
    Dec 29, 2009
    Occupation:
    Business owner/service and sales
    Location:
    Alaska
    Or a crack in the media tank.

    Seen one do that about a year ago.
     
  5. pgdaboys

    pgdaboys New Member

    Joined:
    Jan 10, 2010
    Location:
    Texas
    Thanks guys - I was afraid you'd say that! I guess that gives me another project :)
     
  6. Akpsdvan

    Akpsdvan In the Trades

    Joined:
    Dec 29, 2009
    Occupation:
    Business owner/service and sales
    Location:
    Alaska
    Let us and the others know what you find out as to where the leak is at.
     
  7. Skip Wolverton

    Skip Wolverton In the Trades

    Joined:
    Dec 27, 2009
    Occupation:
    Owner of SWS Systems. I work on most water treatme
    Location:
    Ocala, Fl
    The drain seal inside the valve is springed assisted. I've seen the stick and run to the drain. If it is weak, maybe the flow to the tub allows the drain seal to open. Just a thought.
     
Similar Threads: Kenmore Water
Forum Title Date
Water Softener Forum, problems, installation and r No soft water / no salt usage with Kenmore 300 Feb 17, 2015
Water Softener Forum, problems, installation and r Kenmore Water Softener white 1" Disk Nov 27, 2014
Water Softener Forum, problems, installation and r Kenmore 350 watersoftner board fix for free! Oct 4, 2014
Water Softener Forum, problems, installation and r Kenmore water softner Oct 3, 2014
Water Softener Forum, problems, installation and r Kenmore water softener not working properly (no soft water) (no suction) Jan 8, 2014

Share This Page