Kenmore Ultrasoft 200 water softener torubleshooting

Discussion in 'Plumbing Forum, Professional & DIY Advice, Tips & ' started by shahriar, Apr 10, 2010.

  1. shahriar

    shahriar New Member

    Messages:
    1
    Location:
    Minneapolis
    My water softener Kenmore Ultrasoft 200 has a few problems:

    1) Water leaking out of the back overfill nozzle ( OK, ...I fixed that by re-attaching the black brine tubing which threads up from inside of the tank to the Nozzle Assembly). Now, no more leaks.

    2) Water about 3-4 inches over the salt inside of the main tank ( dont know how that happened in the first place) and now, how do I purge that water out, before I can dig all the salt out.

    3) We have hard water now, no soft water.

    4) I checked the nozzle assembly, took out the flow valve (I was told to do so), put the filter screen back properly. I did a 're-charge' cycle several times....I hear pump running, water flowing ( but the brine well doesnt fill up with water - should it ?)

    5) What is the next step ?
    Last edited: Apr 10, 2010
  2. nhmaster3015

    nhmaster3015 Master Plumber

    Messages:
    836
    Location:
    The granite state
    If you go onto the Sears/Kenmore web site there is a whole animated troubleshooting thing there that will take you through their product step by step.
Similar Threads: Kenmore Ultrasoft
Forum Title Date
Plumbing Forum, Professional & DIY Advice, Tips & Kenmore dishwasher Jun 22, 2014
Plumbing Forum, Professional & DIY Advice, Tips & Kenmore Fridge Ice Maker Not Freezing Dec 24, 2013
Plumbing Forum, Professional & DIY Advice, Tips & Kenmore disposal problem Dec 16, 2013
Plumbing Forum, Professional & DIY Advice, Tips & Kenmore in door water despenser Mar 3, 2013
Plumbing Forum, Professional & DIY Advice, Tips & kenmore stackable washer 88732 Jan 10, 2011

Share This Page