Kenmore ultra 800 water softener problem

Discussion in 'Plumbing Forum, Professional & DIY Advice, Tips & ' started by dvg, Jul 20, 2007.

  1. dvg

    dvg New Member

    Messages:
    1
    I have two problems with my kenmore water softener...one is the water in the salt tank will not drain and the water in the house taste really salty. I have replaced the venturi gasket and cleaned that whole thing and tried to drain the water by forcing it in the brine cycle with the transformer unplugged with no luck of getting the salt water level in the brine tank to go down. I talked with kenmore and they said it might be the Oring Kit for Distributor ( Riser ) pipe and valve to tank. My question is i'm not quite sure how to get to that set of orings ? Can I dissamble the valve top assembly and replace the oring set of 3 or do I have to shut the water off and disconnect the valve assembly from the main, or is this even the problem? Any help would be much appreciated as I'm trying to avoid calling them to replace orings and gaskets and pay $300 plus dollars. I just can;t seem to visualize how to get to those orings without disrupting the main water supply. I hope that I can get to it by throwing the bypass and dissassembling the top valve assy?

    thanks!
  2. Gary Slusser

    Gary Slusser That's all folks!

Similar Threads: Kenmore ultra
Forum Title Date
Plumbing Forum, Professional & DIY Advice, Tips & Kenmore Ultrasoft 200 water softener torubleshooting Apr 10, 2010
Plumbing Forum, Professional & DIY Advice, Tips & Kenmore dishwasher Jun 22, 2014
Plumbing Forum, Professional & DIY Advice, Tips & Kenmore Fridge Ice Maker Not Freezing Dec 24, 2013
Plumbing Forum, Professional & DIY Advice, Tips & Kenmore disposal problem Dec 16, 2013
Plumbing Forum, Professional & DIY Advice, Tips & Kenmore in door water despenser Mar 3, 2013

Share This Page