kenmore softner water from drain keeps flowing

Discussion in 'Water Softener Forum, problems, installation and r' started by rfhjr, Jul 11, 2013.

  1. rfhjr

    rfhjr New Member

    Messages:
    3
    Location:
    North Carolina
    The Kenmore water softener model 625383760 the water flows from drain and will not stop unless I force the regeneration cycle to close the valve. Once this is done the machine works for a few days and then the same drain problem occurs. As the rotor turns and the wire connections are okay the technician at Sears seems to think the electronic panel is the problem. Since this part cost about $200 I was thinking it is not really worth it. Since the unit is only 3 years old I was writing to ask if anyone else had any opinions on what the problem could be with this unit.
  2. ditttohead

    ditttohead Water systems designer, R&D

    Messages:
    1,791
    Location:
    Ontario California
    Landfill material. Sorry to say, but only Sears will touch the unit, most softener technicians wont.
  3. mialynette2003

    mialynette2003 Member

    Messages:
    720
    Location:
    Ocala, Florida
    I believe the stem on the rotor is twisted cause by the rotor seal. Replacing both will solve the problem of the time being then the same thing will happen with the new parts. I agree with Dittohead, landfill material.
  4. rfhjr

    rfhjr New Member

    Messages:
    3
    Location:
    North Carolina
    Thank you for the feedback. What is unusual with this unit is after I force the regeneration cycle it may work for 3 days and then the same problem occurs where it gets stuck in the drain mode. Sometimes I get an Err 4 code but usually if I unplug the unit to reset it goes away.
  5. Larry Livingston

    Larry Livingston New Member

    Messages:
    1
    Location:
    Minnesota
    I have one of these softners and if you open the head you'll often find an o-ring trapped in the rotor mechanism. The first time it happened the machine was about 5 years old and it repeated about 2-3 years later. If you have the continuous slow trickle of water when the softener is in service mode, check for the o-ring that goes on the top of the resin tank. It's about 1 inches in diameter and often seems to work loose allowing water to avoid going through the resin tank and to overflow out the drain pipe. You'll hear a sound like the machine is in recharge mode.

    You'll have to remove the entire head and you'll see a tube opening that goes into the tank and a netting material on the outside. The input into the resin tank is like two tubes with one inside the other. The inner tube is smaller and creates a channel for the o-ring to sit in. Place the o-ring in the channel and reinstall the head of the unit.
Similar Threads: kenmore softner
Forum Title Date
Water Softener Forum, problems, installation and r Kenmore water softner overlflows out hole at top of tank Sep 1, 2013
Water Softener Forum, problems, installation and r Kenmore water softner not drawing brine Nov 13, 2011
Water Softener Forum, problems, installation and r Kenmore water softner: Water going in drain pipe continuously Jan 10, 2010
Water Softener Forum, problems, installation and r Guide to take head off of Kenmore Ultrasoft 275? Monday at 1:00 AM
Water Softener Forum, problems, installation and r Replacing Kenmore softener with Fleck 5600 SXT based system... May 31, 2014

Share This Page