Kenmore Softener Problems

Discussion in 'Water Softener Forum, problems, installation and r' started by btb079, Jun 2, 2011.

  1. btb079

    btb079 New Member

    Messages:
    2
    Location:
    Wisconsin
    I have a Kenmore UltraSoft 250. It was in the house when we moved in 5 years ago. It has never really seemed to soften the water. The resin tank was replaced in 2007 because it cracked and flooded the basement, but that is a different story.

    Like I said the water softener has never really seemed to work right. It goes through salt, but the water doesn't seem soften whether it's set to the lowest setting or the highest. I've pulled out and cleaned the nozzle/venturi several times, but it doesn't make a difference. I've also gone through the troubleshooting steps on Kenmore's site. Recently, we've been getting a slight sulfur smell from the softened water, but last night a put some bleach in the brine and ran a regeneration and it seems to have gone away.

    Can anyone give me some other ideas to try to fix this? I'd like to try to fix this myself before buying another one.

    Thanks,
    Bill
  2. Akpsdvan

    Akpsdvan In the Trades

    Messages:
    1,483
    Location:
    Alaska
    Start with a test of the water before the system and after the system.
    There might be a blow by leak, untreated water getting to the treated side.
    One point could the the bypass handle not seated all the way to service, the other could be that the disc seal is broken and letting water cross within the valve or that the o ring on the distributor is missing ....
  3. DonL

    DonL Jack of all trades Master of one

    Messages:
    4,161
    Location:
    Houston, TX
    Hello Bill, Welcome to Terry's Forums,

    I would replace the unit, Then you know your starting point.

    You can get a test kit and determine the hardness level that you have , then go from there.

    Parts are available for the Kenmore, But a replacement would be best. Sears does back their product.


    Have a Great Day.


    DonL
  4. btb079

    btb079 New Member

    Messages:
    2
    Location:
    Wisconsin
    Thanks for the replies. Where would one get a water test kit?
  5. Akpsdvan

    Akpsdvan In the Trades

    Messages:
    1,483
    Location:
    Alaska
    Box stores might, local hardware store might.
  6. DonL

    DonL Jack of all trades Master of one

    Messages:
    4,161
    Location:
    Houston, TX
Similar Threads: Kenmore Softener
Forum Title Date
Water Softener Forum, problems, installation and r Replacing Kenmore softener with Fleck 5600 SXT based system... May 31, 2014
Water Softener Forum, problems, installation and r Kenmore water softener not working properly (no soft water) (no suction) Jan 8, 2014
Water Softener Forum, problems, installation and r Kenmore water softener 625.388150 Nov 15, 2013
Water Softener Forum, problems, installation and r need advice, 12 year old Kenmore water softener Nov 14, 2013
Water Softener Forum, problems, installation and r Kenmore water softener problem; repair or replace? Feb 5, 2013

Share This Page