J-Class Well Water Pump S1CY-S Not Pumping Water

Discussion in 'Pumps and Tanks Well Forum & Blog' started by dfannin, Apr 14, 2013.

  1. dfannin

    dfannin New Member

    Messages:
    1
    Location:
    Vero Beach FL
    Hi All,

    Recently we noticed our water pump had a minor leak. Before we could fix the leak the pump stopped pumping all together. We have since sealed all the leaks but this did not resolve the problem. What is happening is the pump will turn on for about 30 seconds and then it shuts off. We noticed the pump itself was very hot. Do you know anything about the insides of the pump and what could be going on?
  2. DonL

    DonL Banned

    Messages:
    4,007
    Location:
    Houston, TX

    Not sure what kind of leak you had, pump seal or what ?

    If water got into the Start Switch it could be stuck in start or not making contact.

    Does it pump water ?

    You could have a bad run capacitor also.

    It you replaced the pump seal, then the Impeller could be out of center alignment and rubbing on the pump housing.


    Good Luck
Similar Threads: J-Class Water
Forum Title Date
Pumps and Tanks Well Forum & Blog Franklin J-Class Pumps Apr 19, 2012
Pumps and Tanks Well Forum & Blog Pump quits overnight, no water mornings Saturday at 5:36 PM
Pumps and Tanks Well Forum & Blog Running out of water Suggestions please. Aug 23, 2014
Pumps and Tanks Well Forum & Blog Well Water Hammer Aug 18, 2014
Pumps and Tanks Well Forum & Blog Delay in getting water after pressure switch cut-in Aug 17, 2014

Share This Page