Installed shower cartridge, now I get hardly any water flow

Discussion in 'Shower & Bathtub Forum & Blog' started by baka98, Feb 17, 2009.

  1. baka98

    baka98 New Member

    Joined:
    Feb 17, 2009
    What am I doing wrong? I even put the old cartridge in, and now I have the same problem with that too. Please help!!
     
  2. krow

    krow Plumber

    Joined:
    Feb 11, 2008
    Occupation:
    Plumber
    Location:
    Ontario, Canada
    What is the make and model of your faucet. Is it kitchen, lav, tub and shower , etc.......
     
  3. Sponsor

    Sponsor Paid Advertisement

     
  4. baka98

    baka98 New Member

    Joined:
    Feb 17, 2009
    It is a Price-Pfister shower with an Avante cartridge (S74-292).

    The old cartridge came out with no problem, I put in the new one and attached the handle and now I get hardly any flow out of my shower. I tried to put the old cartridge back in and have the same problem.

    Am I putting the cartridge in wrong? There are really only 2 ways to put it in that I can see and I've tried both with no success. Am I an idiot or what?
     
  5. krow

    krow Plumber

    Joined:
    Feb 11, 2008
    Occupation:
    Plumber
    Location:
    Ontario, Canada
    Have you tried pulling off the shower head to make sure nothing is blocking the shower head holes? Sometimes some debris comes loose and pushed up to the head.
     
  6. baka98

    baka98 New Member

    Joined:
    Feb 17, 2009
    Yes. I've taken off the head and the hose and the flow is very low coming out of the pipe. I have no idea what's wrong.
     
  7. baka98

    baka98 New Member

    Joined:
    Feb 17, 2009
    I am an idiot. I forgot to check the filter on my ball joint.
    Problem solved.
     
Similar Threads: Installed shower
Forum Title Date
Shower & Bathtub Forum & Blog Was this shower drain installed incorrectly? Mar 7, 2015
Shower & Bathtub Forum & Blog Questions about a newly installed shower stall. Nov 25, 2014
Shower & Bathtub Forum & Blog Shower Valve installed too far forward Aug 14, 2014
Shower & Bathtub Forum & Blog Delta tub and shower facet installed..little drip Jun 11, 2012
Shower & Bathtub Forum & Blog Moen Shower-Tub Faucet Installed Wrong??? Feb 14, 2012

Share This Page